summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorSonic Zhang <sonic.zhang@analog.com>2013-05-03 00:39:36 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-05 22:49:50 +0200
commit66d41890ec2b76189bcd427a0cc3966ff56f9712 (patch)
tree0eaf64a72c090c74a349b3bc55c4610f84ebbc84 /toolchain/toolchain-external
parent371e6dc7801cbc52cba1e8501cde3c7cd308f28a (diff)
downloadbuildroot-novena-66d41890ec2b76189bcd427a0cc3966ff56f9712.tar.gz
buildroot-novena-66d41890ec2b76189bcd427a0cc3966ff56f9712.zip
arch: toolchain: Introduce target CPU revision.
Adds the possibility to have a free-form CPU revision string and append it to the target CPU. Only Blackfin actually uses this option. Signed-off-by: Sonic Zhang <sonic.zhang@analog.com> Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/ext-tool.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index dce0299be..bf2bee868 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -134,7 +134,11 @@ TOOLCHAIN_EXTERNAL_WRAPPER_ARGS += \
endif
CC_TARGET_TUNE_:=$(call qstrip,$(BR2_GCC_TARGET_TUNE))
+ifeq ($(call qstrip,$(BR2_GCC_TARGET_CPU_REVISION)),)
CC_TARGET_CPU_:=$(call qstrip,$(BR2_GCC_TARGET_CPU))
+else
+CC_TARGET_CPU_:=$(call qstrip,$(BR2_GCC_TARGET_CPU)-$(BR2_GCC_TARGET_CPU_REVISION))
+endif
CC_TARGET_ARCH_:=$(call qstrip,$(BR2_GCC_TARGET_ARCH))
CC_TARGET_ABI_:=$(call qstrip,$(BR2_GCC_TARGET_ABI))