summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-external
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-11-27 04:07:01 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-27 17:11:29 -0800
commit008f635d29310b55e0bb3e9a1a6009f12f7f7400 (patch)
tree3eb26ab4453c3b43a557e127491b775303d71b16 /toolchain/toolchain-external
parentd69172d7d807769f5091a612f7145bd464c7bc82 (diff)
downloadbuildroot-novena-008f635d29310b55e0bb3e9a1a6009f12f7f7400.tar.gz
buildroot-novena-008f635d29310b55e0bb3e9a1a6009f12f7f7400.zip
toolchain-external: add Linaro 2012.11
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-external')
-rw-r--r--toolchain/toolchain-external/Config.in18
-rw-r--r--toolchain/toolchain-external/ext-tool.mk3
2 files changed, 21 insertions, 0 deletions
diff --git a/toolchain/toolchain-external/Config.in b/toolchain/toolchain-external/Config.in
index f04ced697..56630fa4f 100644
--- a/toolchain/toolchain-external/Config.in
+++ b/toolchain/toolchain-external/Config.in
@@ -3,6 +3,23 @@ if BR2_TOOLCHAIN_EXTERNAL
choice
prompt "Toolchain"
+config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11
+ bool "Linaro 2012.11"
+ depends on BR2_arm
+ depends on BR2_cortex_a8 || BR2_cortex_a9
+ select BR2_TOOLCHAIN_EXTERNAL_GLIBC
+ select BR2_TOOLCHAIN_HAS_NATIVE_RPC
+ select BR2_INSTALL_LIBSTDCPP
+ help
+ Linaro toolchain for the ARM architecture. It uses Linaro
+ GCC 2012.11 (based on gcc 4.7), Linaro GDB 2012.10 (based on
+ GDB 7.5), eglibc 2.15. It generates code that runs on all
+ Cortex-A profile devices, but tuned for the Cortex-A9. The
+ code generated is Thumb 2, with the hard floating point
+ calling convention, and uses the VFPv3-D16 FPU instructions.
+
+ To use this toolchain, you must disable soft float usage.
+
config BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
bool "Linaro 2012.10"
depends on BR2_arm
@@ -627,6 +644,7 @@ config BR2_TOOLCHAIN_EXTERNAL_PREFIX
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_08
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_09
default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10
+ default "arm-linux-gnueabihf" if BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201103
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201109
default "arm-none-linux-gnueabi" if BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_ARM201203
diff --git a/toolchain/toolchain-external/ext-tool.mk b/toolchain/toolchain-external/ext-tool.mk
index a6025dbdd..d98fcc6b8 100644
--- a/toolchain/toolchain-external/ext-tool.mk
+++ b/toolchain/toolchain-external/ext-tool.mk
@@ -193,6 +193,9 @@ TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-2012.09-20120921_linux.
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_10),y)
TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.10/+download/
TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.10-20121022_linux.tar.bz2
+else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_LINARO_2012_11),y)
+TOOLCHAIN_EXTERNAL_SITE=https://launchpad.net/linaro-toolchain-binaries/trunk/2012.11/+download/
+TOOLCHAIN_EXTERNAL_SOURCE=gcc-linaro-arm-linux-gnueabihf-4.7-2012.11-20121123_linux.tar.bz2
else ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_MIPS44),y)
TOOLCHAIN_EXTERNAL_SITE=http://sourcery.mentor.com/sgpp/lite/mips/portal/package7401/public/mips-linux-gnu/
TOOLCHAIN_EXTERNAL_SOURCE=mips-4.4-303-mips-linux-gnu-i686-pc-linux-gnu.tar.bz2