summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-crosstool-ng
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2011-02-09 23:57:22 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-10 11:23:59 +0100
commit835357388ff591e3d431cbcecf75842a428b4f4a (patch)
treec9c1e42c0be2d56b3f4280e186c44c450bf81553 /toolchain/toolchain-crosstool-ng
parenta8e4599212f5e5303a523b4cbdcbe8ed5cd9a52d (diff)
downloadbuildroot-novena-835357388ff591e3d431cbcecf75842a428b4f4a.tar.gz
buildroot-novena-835357388ff591e3d431cbcecf75842a428b4f4a.zip
toolchain/ct-ng: use soft-float option from BR config
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-crosstool-ng')
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index 553d93b06..d066e9832 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -191,7 +191,7 @@ endif
#
# Lots of other awfull sed manipulations go here, to override CT-NG's .config
# with BR2 config options.
-# Known missing: arch options, floating point (HW/SW), uClibc/eglibc config...
+# Known missing: arch options, uClibc/eglibc config...
#
CTNG_FIX_DOT_CONFIG_SED += s:^(CT_INSTALL_DIR_RO)=y:\# \1 is not set:;
CTNG_FIX_DOT_CONFIG_SED += s:^(|\# )(CT_ARCH_[BL]E).*:\# \2 is not set:;
@@ -223,6 +223,15 @@ ifneq ($(call qstrip,$(BR2_GCC_TARGET_TUNE)),)
CTNG_FIX_DOT_CONFIG_SED += s:^(CT_ARCH_TUNE)=.*:\1=$(BR2_GCC_TARGET_TUNE):;
endif
+# And floating point now
+ifeq ($(call qstrip,$(BR2_SOFT_FLOAT)),)
+CTNG_FIX_DOT_CONFIG_SED += s:^\# (CT_ARCH_FLOAT_HW) is not set:\1=y:;
+CTNG_FIX_DOT_CONFIG_SED += s:^(CT_ARCH_FLOAT_SW)=y:\# \1 is not set:;
+else
+CTNG_FIX_DOT_CONFIG_SED += s:^(CT_ARCH_FLOAT_HW)=y:\# \1 is not set:;
+CTNG_FIX_DOT_CONFIG_SED += s:^\# (CT_ARCH_FLOAT_SW) is not set:\1=y:;
+endif
+
# Thread implementation selection
CTNG_FIX_DOT_CONFIG_SED += s:^(|\# )(CT_THREADS_NONE).*:\# \2 is not set:;
CTNG_FIX_DOT_CONFIG_SED += s:^(|\# )(CT_THREADS_LINUXTHREADS).*:\# \2 is not set:;