summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-crosstool-ng
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2011-02-16 00:41:42 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-02-17 14:05:47 +0100
commit5ad362125949b5412938f96f7f433847674f8f60 (patch)
treef38bbe0edab15dd586d765ebff31d2cd60eb4075 /toolchain/toolchain-crosstool-ng
parent0be744e49590c32a1fb9141f4a0ef617b62b27c4 (diff)
downloadbuildroot-novena-5ad362125949b5412938f96f7f433847674f8f60.tar.gz
buildroot-novena-5ad362125949b5412938f96f7f433847674f8f60.zip
toolchain/ct-ng: use program_invocation_name option from BR config
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-crosstool-ng')
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index d066e9832..8db8eac5c 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -301,6 +301,13 @@ else
CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_RPC)=.*:\# \1 is not set:;
endif
+# Handle the program_invocation_name option
+ifneq ($(call qstrip,$(BR2_PROGRAM_INVOCATION)),)
+CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^\# (UCLIBC_HAS_PROGRAM_INVOCATION_NAME) is not set:\1=y:;
+else
+CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_PROGRAM_INVOCATION_NAME)=y:\# \1 is not set:;
+endif
+
# Instruct CT-NG's .config where to find the uClibc's .config
CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_LIBC_UCLIBC_CONFIG_FILE)=.*:\1="$(CTNG_DIR)/libc.config":;