summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-crosstool-ng
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2011-04-23 18:18:34 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-04-24 22:37:37 +0200
commit4b4e5827a24d8a517038741b681dc077c2f28cf1 (patch)
tree87ed8d21123e3dceffc71afb5b4c3678318c63f7 /toolchain/toolchain-crosstool-ng
parentcd58efbac7040c58429b765853306c3e8052e984 (diff)
downloadbuildroot-novena-4b4e5827a24d8a517038741b681dc077c2f28cf1.tar.gz
buildroot-novena-4b4e5827a24d8a517038741b681dc077c2f28cf1.zip
toolchain/crosstool-NG: correctly copy the dynamic linker
Depending on some setting (which? Arch? Others?), the dynamic linker can get different names. Some times, it is named ld-linux.something.so, other times, it is ld.so.1, and maybe other variants as well... The fix is to always copy ls*.so, even if it is a symlink: we create the destination file by its SONAME, and if ld*.so matches more than one file, that's no issue, as they would all get the same SONAME (being symlinks ones to the others). Split long lines at the same time. Reported-by: Ettore Campion <ecampion@gmail.com> Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-crosstool-ng')
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk7
1 files changed, 4 insertions, 3 deletions
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index e52bdee25..015cd13e6 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -36,13 +36,14 @@ endef
#--------------
# The generic system libraries (in /lib)
-CTNG_LIBS_LIB := libc.so libcrypt.so libdl.so libgcc_s.so libm.so libnsl.so libpthread.so libresolv.so librt.so libutil.so
+CTNG_LIBS_LIB := ld*.so libc.so libcrypt.so libdl.so libgcc_s.so libm.so \
+ libnsl.so libpthread.so libresolv.so librt.so libutil.so
#--------------
# The libc-specific system libraries (in /lib)
# Note: it may be needed to tweak the NSS libs in the glibc and eglibc cases...
-CTNG_LIBS_uClibc := ld-uClibc.so
-CTNG_LIBS_glibc := ld-linux.so libnss_files.so libnss_dns.so
+CTNG_LIBS_uClibc :=
+CTNG_LIBS_glibc := libnss_files.so libnss_dns.so
CTNG_LIBS_eglibc := $(CTNG_LIBS_glibc)
#--------------