summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2011-07-13 01:07:45 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-13 08:31:05 +0200
commitea23f34e25839a9559c3bb61cc5d9f54c89e137b (patch)
treeed9e4ebb66a101b917f094f4d84f1c6ba1dcff16 /toolchain/toolchain-crosstool-ng/crosstool-ng.mk
parent72eb844be64567dadd7d619aa049fafbfa347736 (diff)
downloadbuildroot-novena-ea23f34e25839a9559c3bb61cc5d9f54c89e137b.tar.gz
buildroot-novena-ea23f34e25839a9559c3bb61cc5d9f54c89e137b.zip
toolchain/crosstool-ng: allow pre-downloading the sources
On "make source", just download the required sources, and do not build the entire toolchain. This requires a new patch against crosstool-NG (got from upstream). The "uclibc-source" rule requires an installed and configured crosstool-NG, so it has to be after the variables declaration. For consistency, move down the main rule "uclibc". Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-crosstool-ng/crosstool-ng.mk')
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk17
1 files changed, 12 insertions, 5 deletions
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index 2d1b51c68..d3fcc65ff 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -6,11 +6,6 @@
# except that it is not pre-built.
#-----------------------------------------------------------------------------
-# 'uclibc' is the target to depend on to get the toolchain and prepare
-# the staging directory and co.
-uclibc: dependencies $(STAMP_DIR)/ct-ng-toolchain-installed
-
-#-----------------------------------------------------------------------------
# Internal variables
# Crostool-NG hard-coded configuration options
@@ -33,6 +28,18 @@ PATH=$(HOST_PATH) $(CTNG_DIR)/ct-ng -C $(CTNG_DIR) --no-print-directory $(1)
endef
#-----------------------------------------------------------------------------
+# 'uclibc' is the target to depend on to get the toolchain and prepare
+# the staging directory and co.
+uclibc: dependencies $(STAMP_DIR)/ct-ng-toolchain-installed
+
+# 'uclibc-source' is the target used by the infra structure to mean
+# "we just want to download the toolchain's sources, not build it"
+# For crosstool-NG, we need it to be configured before we can download;
+# then we have to override a config option to just do the download
+uclibc-source: $(CTNG_DIR)/.config
+ $(Q)$(call ctng,build CT_ONLY_DOWNLOAD=y)
+
+#-----------------------------------------------------------------------------
# Installing the libs to target/ and staging/
#--------------