summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2010-11-27 21:50:48 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-11-27 22:29:03 +0100
commit32dd477465f70cb31014967e880c839b713394b1 (patch)
tree7d98f580087983ea04a2fea577d2d3712e956eff /toolchain/toolchain-crosstool-ng/crosstool-ng.mk
parent421b5597f5b8e3d8e2f9f1fb4d6e7bbabd84db0c (diff)
downloadbuildroot-novena-32dd477465f70cb31014967e880c839b713394b1.tar.gz
buildroot-novena-32dd477465f70cb31014967e880c839b713394b1.zip
toolchain/crosstool-NG: use LFS option
Push the LFS option down to uClibc config Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-crosstool-ng/crosstool-ng.mk')
-rw-r--r--toolchain/toolchain-crosstool-ng/crosstool-ng.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
index e944b93a1..97224a1d9 100644
--- a/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
+++ b/toolchain/toolchain-crosstool-ng/crosstool-ng.mk
@@ -238,6 +238,13 @@ else
CTNG_FIX_DOT_CONFIG_SED += s:^(CT_LIBC_UCLIBC_WCHAR)=.*:\# \1 is not set:;
endif
+# Handle the LFS option
+ifneq ($(call qstrip,$(BR2_LARGEFILE)),)
+CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^\# (UCLIBC_HAS_LFS) is not set:\1=y:;
+else
+CTNG_FIX_DOT_CONFIG_LIBC_SED += s:^(UCLIBC_HAS_LFS)=.*:\# \1 is not set:;
+endif
+
# Instruct CT-NG's .config where to find the uClibc's .config
CTNG_FIX_DOT_CONFIG_PATHS_SED += s:^(CT_LIBC_UCLIBC_CONFIG_FILE)=.*:\1="$(CTNG_DIR)/libc.config":;