summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-common.in
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-11-24 14:26:52 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-11-24 14:26:52 +0100
commit5931db0de902d2da434fbf682d4177e3b3c7e31b (patch)
tree7ac68545a58d3b09f482b565df74d5524e979308 /toolchain/toolchain-common.in
parent468f1cac8a2dad537bea6cbdabbf34031ceaae42 (diff)
downloadbuildroot-novena-5931db0de902d2da434fbf682d4177e3b3c7e31b.tar.gz
buildroot-novena-5931db0de902d2da434fbf682d4177e3b3c7e31b.zip
gdb: fix kconfig dependency handling with !BR_TOOLCHAIN_BUILDROOT
Newer versions of GDB need pthread debugging support if threads are enabled, which is always the case for glibc but is a configure option for uClibc. We have solved this for internal toolchains by selecting the BR2_PTHREAD_DEBUG option from the GDB selection if needed, but as this option isn't available when ctng/external toolchains are used, mconf prints ugly warnings and the build may fail if an external uClibc toolchain without pthread debugging support is used. Fix it by introducing 2 more hidden config options: - BR2_TOOLCHAIN_HAS_THREADS_DEBUG - BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED The first tells us if the toolchain HAS pthreads debugging support, and is checked by check_uclibc_feature in helper.mk for external uClibc based toolchains. The second tells us if the toolchain is ABLE TO provide pthreads debugging support if threads are enabled, either because it's an internal toolchain where we can force enable it or an external glibc/eglibc toolchain or uClibc with the option enabled. Crosstool-ng forcibly enables this support, so those will always work. The preconfigured uClibc-based toolchains we have also all enable it. Finally, show a comment if this isn't the case so the (external toolchain) user knows why. This is placed outside the choice option, as menuconfig has a bug where it doesn't show choice selections which only contain comments. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-common.in')
-rw-r--r--toolchain/toolchain-common.in8
1 files changed, 8 insertions, 0 deletions
diff --git a/toolchain/toolchain-common.in b/toolchain/toolchain-common.in
index 2d1100809..56ac85f5c 100644
--- a/toolchain/toolchain-common.in
+++ b/toolchain/toolchain-common.in
@@ -26,6 +26,14 @@ config BR2_INSTALL_LIBSTDCPP
config BR2_TOOLCHAIN_HAS_THREADS
bool
+config BR2_TOOLCHAIN_HAS_THREADS_DEBUG
+ select BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ bool
+
+config BR2_TOOLCHAIN_HAS_THREADS_DEBUG_IF_NEEDED
+ default y if !BR2_TOOLCHAIN_HAS_THREADS
+ bool
+
config BR2_TOOLCHAIN_HAS_SHADOW_PASSWORDS
bool