summaryrefslogtreecommitdiffstats
path: root/toolchain/toolchain-buildroot.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-06-30 21:29:12 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2013-07-04 11:08:27 +0200
commit8d29893893fe25461abef645bfd38bf2f49c59a4 (patch)
treebe15b85d95cfecbda3f0ca34736aed8775b8a7dd /toolchain/toolchain-buildroot.mk
parent413ecfa80faf29b55a94b666c97efea0dc8162d9 (diff)
downloadbuildroot-novena-8d29893893fe25461abef645bfd38bf2f49c59a4.tar.gz
buildroot-novena-8d29893893fe25461abef645bfd38bf2f49c59a4.zip
eglibc: enable support in the Buildroot toolchain backend
Using the newly introduced 'eglibc' package, this commit enables the option of building a toolchain using the eglibc C library in the Buildroot toolchain backend. In details, this commit: * Creates a choice to select uClibc or eglibc in the Buildroot toolchain backend (in toolchain/toolchain-buildroot/Config.in), and removes the fact that the Buildroot toolchain backend forcefully enables uClibc (toolchain/Config.in). * Creates a BUILDROOT_LIBC variables, which points to the package implementing the C library (i.e either 'uclibc' or 'eglibc'). * Modifies the gcc-final and gcc-intermediate makefiles to use the BUILDROOT_LIBC variable instead of hardcoding the use of uclibc. * Ensures that TLS support is always enabled when building eglibc. [Peter: fix commit text to refer to BUILDROOT_LIBC] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/toolchain-buildroot.mk')
-rw-r--r--toolchain/toolchain-buildroot.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/toolchain/toolchain-buildroot.mk b/toolchain/toolchain-buildroot.mk
index e7241bfcf..3a0580066 100644
--- a/toolchain/toolchain-buildroot.mk
+++ b/toolchain/toolchain-buildroot.mk
@@ -2,4 +2,8 @@
# build of binutils, uClibc, kernel headers and all the intermediate
# gcc steps.
+include toolchain/helpers.mk
+
+BUILDROOT_LIBC = $(call qstrip,$(BR2_TOOLCHAIN_BUILDROOT_LIBC))
+
toolchain-buildroot: host-gcc-final