summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-09 19:44:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-10 09:47:23 +0200
commitda6353c9e7e6e6accfe72ee4cb5165bdf580b18a (patch)
treecf44ef064718ab171474f31f9cbe1189ea24e68d /toolchain/helpers.mk
parent2e57043b4d1659b54cd5954ad98884e1a1c3848a (diff)
downloadbuildroot-novena-da6353c9e7e6e6accfe72ee4cb5165bdf580b18a.tar.gz
buildroot-novena-da6353c9e7e6e6accfe72ee4cb5165bdf580b18a.zip
toolchain: speed up sysroot lib copying
The copy_toolchain_lib_root helper searches the entire sysroot, but is only interested in files in certain subdirs. So rather than waste time in walking the entire tree, walk the few subdirs at the depth level we are actually going to be poaching files from. Some simplification suggested by Yann E. MORIN <yann.morin.1998@anciens.enib.fr> and Arnout Vandecappelle <arnout@mind.be>, added by Thomas Petazzoni <thomas.petazzoni@free-electrons.com>. Signed-off-by: Mike Frysinger <vapier@gentoo.org> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 7f3efaa40..5585f45fe 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -22,9 +22,8 @@ copy_toolchain_lib_root = \
DESTDIR="$(strip $3)" ; \
\
LIBS=`(cd $${ARCH_SYSROOT_DIR}; \
- find -L . -path "./lib/$${LIB}.*" -o \
- -path "./usr/lib/$${LIB}.*" -o \
- -path "./usr/$(TOOLCHAIN_EXTERNAL_PREFIX)/lib*/$${LIB}.*" \
+ find -L lib* usr/lib* usr/$(TOOLCHAIN_EXTERNAL_PREFIX)/lib* \
+ -maxdepth 1 -name "$${LIB}.*" 2>/dev/null \
)` ; \
for FILE in $${LIBS} ; do \
LIB=`basename $${FILE}`; \