summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-10-13 13:18:51 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-11-02 12:28:41 +0100
commitd453d0bc9c15fb0f15f116cbe0c14ce7cd9501ec (patch)
treeef2c2ae70cf66926a15236a80fc29208e21fffa7 /toolchain/helpers.mk
parent922f19fe80358403e29b14c6e8f1f32821d467c9 (diff)
downloadbuildroot-novena-d453d0bc9c15fb0f15f116cbe0c14ce7cd9501ec.tar.gz
buildroot-novena-d453d0bc9c15fb0f15f116cbe0c14ce7cd9501ec.zip
ext-toolchain: fix ct-ng as external rsync issues
When using a CT-NG toolchain as external toolchain (not with the integration) and said toolchain has u-w directories rsync fails. So instruct rsync to chmod u+w directories in the target copy to avoid the issue. [Peter: notice that this is a workaround for a rsync 3.0.8 bug] Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 5585f45fe..96919d4b1 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -91,7 +91,7 @@ copy_toolchain_sysroot = \
ARCH_SUBDIR="$(strip $3)"; \
for i in etc lib sbin usr ; do \
if [ -d $${ARCH_SYSROOT_DIR}/$$i ] ; then \
- rsync -au --exclude 'usr/lib/locale' $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
+ rsync -au --chmod=Du+w --exclude 'usr/lib/locale' $${ARCH_SYSROOT_DIR}/$$i $(STAGING_DIR)/ ; \
fi ; \
done ; \
if [ `readlink -f $${SYSROOT_DIR}` != `readlink -f $${ARCH_SYSROOT_DIR}` ] ; then \