summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@anciens.enib.fr>2010-09-20 23:26:06 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2010-09-30 22:08:54 +0200
commitd12bc6294a37d52150fe14292d4e84d7a70e4861 (patch)
tree3c71d02e13c139adbb79f22fbb242d9f9f8236c8 /toolchain/helpers.mk
parentb8ce1fb184e1308a53ab7f58a1fbcf8add0c3c73 (diff)
downloadbuildroot-novena-d12bc6294a37d52150fe14292d4e84d7a70e4861.tar.gz
buildroot-novena-d12bc6294a37d52150fe14292d4e84d7a70e4861.zip
toolchain: fix helpers for POSIX compliance
Using two '=' for string comparison is a bashism. Revert to using one, as stated in POSIX 1003.1-2008. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@anciens.enib.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 5c87d2bfa..05d43e788 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -170,11 +170,11 @@ check_glibc = \
#
check_uclibc_feature = \
IS_IN_LIBC=`grep -q "\#define $(1) 1" $(3) && echo y` ; \
- if [ x$($(2)) != x"y" -a x$${IS_IN_LIBC} == x"y" ] ; then \
+ if [ x$($(2)) != x"y" -a x$${IS_IN_LIBC} = x"y" ] ; then \
echo "$(4) available in C library, please enable $(2)" ; \
exit 1 ; \
fi ; \
- if [ x$($(2)) == x"y" -a x$${IS_IN_LIBC} != x"y" ] ; then \
+ if [ x$($(2)) = x"y" -a x$${IS_IN_LIBC} != x"y" ] ; then \
echo "$(4) not available in C library, please disable $(2)" ; \
exit 1 ; \
fi
@@ -214,11 +214,11 @@ check_arm_abi = \
else \
EXT_TOOLCHAIN_ABI="oabi" ; \
fi ; \
- if [ x$(BR2_ARM_OABI) == x"y" -a $${EXT_TOOLCHAIN_ABI} == "eabi" ] ; then \
+ if [ x$(BR2_ARM_OABI) = x"y" -a $${EXT_TOOLCHAIN_ABI} = "eabi" ] ; then \
echo "Incorrect ABI setting" ; \
exit 1 ; \
fi ; \
- if [ x$(BR2_ARM_EABI) == x"y" -a $${EXT_TOOLCHAIN_ABI} == "oabi" ] ; then \
+ if [ x$(BR2_ARM_EABI) = x"y" -a $${EXT_TOOLCHAIN_ABI} = "oabi" ] ; then \
echo "Incorrect ABI setting" ; \
exit 1 ; \
fi ; \