summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-12-21 13:49:37 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2010-12-21 13:57:11 +0100
commitcd11bf49704ef6413ae303c6c774b5c6a4a62f9a (patch)
treea55d01f0fe2bf5320576a0ccab80e43775d79e56 /toolchain/helpers.mk
parent5366b4fa9972f3372711f7f69810c0fcef183b07 (diff)
downloadbuildroot-novena-cd11bf49704ef6413ae303c6c774b5c6a4a62f9a.tar.gz
buildroot-novena-cd11bf49704ef6413ae303c6c774b5c6a4a62f9a.zip
toolchain: fix multilib symlink for external toolchains
ARCH_SUBDIR is a shell variable, so it should be referenced with $${ARCH_SUBDIR}. Without this, no symbolic link is created, and the external toolchain fails to work if the non-default multilib variant is used. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 9b37f3f6c..eb9d7421d 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -96,7 +96,7 @@ copy_toolchain_sysroot = \
if [ ! -d $${ARCH_SYSROOT_DIR}/usr/include ] ; then \
cp -a $${SYSROOT_DIR}/usr/include $(STAGING_DIR)/usr ; \
fi ; \
- ln -s . $(STAGING_DIR)/$(ARCH_SUBDIR) ; \
+ ln -s . $(STAGING_DIR)/$${ARCH_SUBDIR} ; \
fi ; \
find $(STAGING_DIR) -type d | xargs chmod 755