summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorJean-Mickael Guerin <jean-mickael.guerin@6wind.com>2012-10-12 10:25:50 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-10-20 21:05:39 +0200
commitc8fd94218ee6284061552ca5de2256417a21bcb9 (patch)
tree5a91dd7bb6f03f02cedde166191b3ec041c29814 /toolchain/helpers.mk
parent7aed4faa9b0e6b21dba82ad5d3be5db796517580 (diff)
downloadbuildroot-novena-c8fd94218ee6284061552ca5de2256417a21bcb9.tar.gz
buildroot-novena-c8fd94218ee6284061552ca5de2256417a21bcb9.zip
toolchain: have check_glibc to search deeper for ld-linux
ld-linux*.so may not be present in lib/ directory, it could be in lib32 and/or lib64 only. But check_glibc reports "Incorrect selection of the C library" in this case, which is not true. Fixed by extending the search to SYSROOT/*/*. Signed-off-by: Jean-Mickael Guerin <jean-mickael.guerin@6wind.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index d5ab91b3d..497cfff22 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -196,7 +196,7 @@ check_glibc_feature = \
#
check_glibc = \
SYSROOT_DIR="$(strip $1)"; \
- if test `find $${SYSROOT_DIR}/lib/ -maxdepth 1 -name 'ld-linux*.so.*' -o -name 'ld.so.*' | wc -l` -eq 0 ; then \
+ if test `find $${SYSROOT_DIR}/ -maxdepth 2 -name 'ld-linux*.so.*' -o -name 'ld.so.*' | wc -l` -eq 0 ; then \
echo "Incorrect selection of the C library"; \
exit -1; \
fi; \