summaryrefslogtreecommitdiffstats
path: root/toolchain/helpers.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2011-12-31 16:15:43 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-03-01 20:26:38 +0100
commit090d486441e6ee1898a6a27f8827076464cf2110 (patch)
treeec8ef545192e602101f6ead0f041f281fc5d4ee4 /toolchain/helpers.mk
parent3367d5ce770ac409e7b3f5bba2c7ed1a819b3ef7 (diff)
downloadbuildroot-novena-090d486441e6ee1898a6a27f8827076464cf2110.tar.gz
buildroot-novena-090d486441e6ee1898a6a27f8827076464cf2110.zip
external-toolchain: adjust check for uClibc static toolchains
The current check for uClibc toolchain was verifying that a ld-uClibc.so dynamic loader was present. However, with static-only uClibc toolchains, this does not work. Instead, we check for an uClibc-specific header file in the sysroot. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'toolchain/helpers.mk')
-rw-r--r--toolchain/helpers.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/toolchain/helpers.mk b/toolchain/helpers.mk
index 3f4818f22..6e7f1f4c9 100644
--- a/toolchain/helpers.mk
+++ b/toolchain/helpers.mk
@@ -196,7 +196,7 @@ check_uclibc_feature = \
#
check_uclibc = \
SYSROOT_DIR="$(strip $1)"; \
- if ! test -f $${SYSROOT_DIR}/lib/ld*-uClibc.so.* ; then \
+ if ! test -f $${SYSROOT_DIR}/usr/include/bits/uClibc_config.h ; then \
echo "Incorrect selection of the C library"; \
exit -1; \
fi; \