summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-04-11 08:21:55 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-04-11 08:21:55 +0000
commitdc09df0878191f7b9fa055d40a1a423fd34b7971 (patch)
tree0ff63c1e03c691708c80e38e17a01712113507aa /target
parent73be7f9ef4b22e6250b77dda2d1a72245f6ce36d (diff)
downloadbuildroot-novena-dc09df0878191f7b9fa055d40a1a423fd34b7971.tar.gz
buildroot-novena-dc09df0878191f7b9fa055d40a1a423fd34b7971.zip
- store BR2_PACKAGE_LINUX_KCONFIG and BR2_PACKAGE_LINUX_FORMAT in .config
- adjust a few defaults.
Diffstat (limited to 'target')
-rw-r--r--target/device/Config.in30
-rw-r--r--target/device/x86/i386/Makefile.in12
2 files changed, 41 insertions, 1 deletions
diff --git a/target/device/Config.in b/target/device/Config.in
index 15abad8f6..cbad6fd6b 100644
--- a/target/device/Config.in
+++ b/target/device/Config.in
@@ -11,6 +11,36 @@ config BR2_PACKAGE_LINUX
kernel headers are just that (headers) and not full
kernels. This is a feature.
+config BR2_PACKAGE_LINUX_KCONFIG
+ string ".config file"
+ depends on BR2_PACKAGE_LINUX
+ default ""
+ help
+ kernel's .config to use to build a kernel for the target.
+
+ If the above setting is empty, you can change the default
+ board-imposed value by passing LINUX26_KCONFIG=<path> to
+ make.
+
+config BR2_PACKAGE_LINUX_FORMAT
+ string "kernel binary format"
+ depends on BR2_PACKAGE_LINUX
+ default ""
+ help
+ kernel binary format.
+ Popular values include:
+ - bzImage
+ - zImage
+ and other, architecture dependant formats.
+
+ Note that the default format is supposed to be set by your
+ board-description, if any.
+ i386 and compatible default to bzImage if nothing was given
+ above.
+ If the above setting is empty, you can change the default
+ board-imposed value by passing LINUX26_FORMAT=<string> to
+ make.
+
source "target/device/AMD/Config.in"
source "target/device/Arm/Config.in"
source "target/device/Atmel/Config.in"
diff --git a/target/device/x86/i386/Makefile.in b/target/device/x86/i386/Makefile.in
index 876304b7e..08ae1b1a2 100644
--- a/target/device/x86/i386/Makefile.in
+++ b/target/device/x86/i386/Makefile.in
@@ -1,7 +1,17 @@
BR2_BOARD_PATH:=target/device/x86/i386
+ifeq ($(strip $(BR2_PACKAGE_LINUX_KCONFIG)),)
ifndef LINUX26_KCONFIG
LINUX26_KCONFIG=$(BR2_BOARD_PATH)/linux26.config
endif
-LINUX26_FORMAT=bzImage
+else
+LINUX26_KCONFIG=$(strip $(BR2_PACKAGE_LINUX_KCONFIG))
+endif
+ifeq ($(strip $(BR2_PACKAGE_LINUX_FORMAT)),)
+ifndef LINUX26_FORMAT
+LINUX26_FORMAT=bzImage
+endif
+else
+LINUX26_FORMAT=$(strip $(BR2_PACKAGE_LINUX_FORMAT))
+endif