summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-06 14:40:24 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2009-01-06 14:40:24 +0000
commitb33e097596b6ea228acb6107eb5f8a2169735953 (patch)
tree889f5929ffa6ad726e759a380d4c5dfd08e55cbf /target
parent6bcd872614fbb7cd3295e41da5d68002bdc8663c (diff)
downloadbuildroot-novena-b33e097596b6ea228acb6107eb5f8a2169735953.tar.gz
buildroot-novena-b33e097596b6ea228acb6107eb5f8a2169735953.zip
When you set BR2_PACKAGE_LINUX_USE_DEFCONFIG
to configure linux using the make <board>_defconfig You have to supply the $(BOARD_NAME) variable. Add this info in the help text for target/linux/Makefile.in.advanced ---------------- When you do not set BR2_PACKAGE_LINUX_USE_XCONFIG to configure linux using "$make <XXXX>config The choices "$make menuconfig" or "$make xconfig" should not be visible. Add dependency
Diffstat (limited to 'target')
-rw-r--r--target/linux/Config.in.advanced5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/Config.in.advanced b/target/linux/Config.in.advanced
index 3b26a899d..6a493116b 100644
--- a/target/linux/Config.in.advanced
+++ b/target/linux/Config.in.advanced
@@ -437,6 +437,8 @@ config BR2_PACKAGE_LINUX_USE_DEFCONFIG
depends on BR2_PACKAGE_LINUX
help
Configure Linux by make <board>_defconfig
+ You have to supply a BOARD_NAME, either by
+ defining it in a BSP or by make BOARD_NAME=<board>
config BR2_PACKAGE_LINUX_USE_XCONFIG
bool "Run make ARCH=$(ARCH) [xconfig|menuconfig] before build"
@@ -445,8 +447,6 @@ config BR2_PACKAGE_LINUX_USE_XCONFIG
Configure Linux by make xconfig
endchoice
-
-
config BR2_PACKAGE_LINUX_KCONFIG
string ".config file"
depends on BR2_PACKAGE_LINUX_USE_KCONFIG
@@ -462,6 +462,7 @@ choice
prompt "Preferred config tool"
default BR2_MAKE_XCONFIG if BR2_TARGET_ATMEL
default BR2_MAKE_MENUCONFIG
+ depends on BR2_PACKAGE_LINUX_USE_XCONFIG
help
Define the preferred tool to invoke if a configuration is invalid