summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 09:22:07 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-08-22 09:22:07 +0000
commitaa81a0650884a0563e6dcb41dc15a5635a28481d (patch)
treead8e2788b9b644366128ded4f25bbe9e7e96b582 /target
parent26b4c3782b0d6b75e1dc4985a5714cf68566b0a8 (diff)
downloadbuildroot-novena-aa81a0650884a0563e6dcb41dc15a5635a28481d.tar.gz
buildroot-novena-aa81a0650884a0563e6dcb41dc15a5635a28481d.zip
- improve the way host prerequisites for "dependencies" are established
Diffstat (limited to 'target')
-rw-r--r--target/linux/Makefile.in10
1 files changed, 1 insertions, 9 deletions
diff --git a/target/linux/Makefile.in b/target/linux/Makefile.in
index 2b9421428..c65e241cb 100644
--- a/target/linux/Makefile.in
+++ b/target/linux/Makefile.in
@@ -59,14 +59,6 @@ ifndef LINUX26_KERNEL
LINUX26_KERNEL=$(BINARIES_DIR)/linux-kernel-$(LINUX26_VERSION)-$(KERNEL_ARCH)
endif
-ifeq ($(BR2_KERNEL_HEADERS_LZMA),y)
-ifeq ($(BR2_KERNEL_HEADERS_LZMA_INSTALL),y)
-DEPEND_ON_HOST_LZMA:=lzma-host-install
-else
-DEPEND_ON_HOST_LZMA:=lzma-host
-endif
-endif
-
# Version of Linux AFTER patches
LINUX26_DIR=$(BUILD_DIR)/linux-$(LINUX26_VERSION)
@@ -165,7 +157,7 @@ linux26-menuconfig: $(LINUX26_DIR)/.patched host-sed
$(MAKE) $(LINUX26_MAKE_FLAGS) -C $(LINUX26_DIR) menuconfig
-[ -f $(LINUX26_DIR)/.config ] && touch $(LINUX26_DIR)/.configured
-linux26: $(DEPEND_ON_HOST_LZMA) $(INITRAMFS_TARGET) $(LINUX26_KERNEL)
+linux26: $(INITRAMFS_TARGET) $(LINUX26_KERNEL)
$(LINUX26_DIR)/.modules_installed: $(TARGET_DIR)/lib/modules/$(LINUX26_VERSION)/modules.dep
touch $@