summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-11-03 08:27:58 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-11-04 12:51:08 +0100
commit6c3e3ad4197714ea39fcd49d572a1713f803d835 (patch)
tree88a5c4db6a9703cc07607b8a0a6f8d14a002a36e /target
parentef1e76ae433e744d2cebf23f1c6d3b6446790270 (diff)
downloadbuildroot-novena-6c3e3ad4197714ea39fcd49d572a1713f803d835.tar.gz
buildroot-novena-6c3e3ad4197714ea39fcd49d572a1713f803d835.zip
New top-level directory: system
This directory groups the following elements: * the default root filesystem skeleton * the default device tables * the Config.in options for system configuration (UART port for getty, system hostname, etc.) * the make rules to apply the system configuration options Even though the skeleton and device tables could have lived in fs/, it would have been strange to have the UART, system hostname and other related options into fs/. A new system/ directory makes more sense. As a consequence, this patch also removes target/Makefile.in, which has become useless in the process. [Peter: fixup TARGET_SKELETON settings / documentation to match] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Yann E. MORIN <yann.morin.1998@free.fr> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'target')
-rw-r--r--target/Makefile.in3
-rw-r--r--target/generic/Config.in184
-rw-r--r--target/generic/Makefile.in53
-rw-r--r--target/generic/device_table.txt22
-rw-r--r--target/generic/device_table_dev.txt146
5 files changed, 0 insertions, 408 deletions
diff --git a/target/Makefile.in b/target/Makefile.in
deleted file mode 100644
index 915d62538..000000000
--- a/target/Makefile.in
+++ /dev/null
@@ -1,3 +0,0 @@
-# make sure to put everything that is board-specific before the tarroot targets
-include target/generic/Makefile.in
-
diff --git a/target/generic/Config.in b/target/generic/Config.in
deleted file mode 100644
index b8472f4e8..000000000
--- a/target/generic/Config.in
+++ /dev/null
@@ -1,184 +0,0 @@
-menu "System configuration"
-
-config BR2_TARGET_GENERIC_HOSTNAME
- string "System hostname"
- default "buildroot"
- help
- Select system hostname to be stored in /etc/hostname.
-
-config BR2_TARGET_GENERIC_ISSUE
- string "System banner"
- default "Welcome to Buildroot"
- help
- Select system banner (/etc/issue) to be displayed at login.
-
-choice
- prompt "/dev management"
- default BR2_ROOTFS_DEVICE_CREATION_STATIC
-
-config BR2_ROOTFS_DEVICE_CREATION_STATIC
- bool "Static using device table"
-
-config BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_DEVTMPFS
- bool "Dynamic using devtmpfs only"
-
-config BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV
- bool "Dynamic using mdev"
- select BR2_PACKAGE_BUSYBOX
-
-config BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV
- bool "Dynamic using udev"
- depends on BR2_LARGEFILE # udev
- depends on BR2_USE_WCHAR # udev
- select BR2_PACKAGE_UDEV
-
-comment "udev requires a toolchain with LARGEFILE + WCHAR support"
- depends on !(BR2_LARGEFILE && BR2_USE_WCHAR)
-
-endchoice
-
-choice
- prompt "Init system"
- default BR2_INIT_BUSYBOX
-
-config BR2_INIT_BUSYBOX
- bool "Busybox"
- select BR2_PACKAGE_BUSYBOX
-
-config BR2_INIT_SYSV
- bool "systemV"
- select BR2_PACKAGE_SYSVINIT
-
-config BR2_INIT_SYSTEMD
- bool "systemd"
- depends on BR2_LARGEFILE
- depends on BR2_USE_WCHAR
- depends on BR2_INET_IPV6
- depends on BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV
- depends on BR2_TOOLCHAIN_HAS_THREADS
- select BR2_PACKAGE_DBUS
- select BR2_PACKAGE_SYSTEMD
-
-comment 'systemd requires largefile, wchar, IPv6, threads and udev support'
- depends on !(BR2_LARGEFILE && BR2_USE_WCHAR && \
- BR2_INET_IPV6 && BR2_TOOLCHAIN_HAS_THREADS && \
- BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV)
-
-config BR2_INIT_NONE
- bool "None"
-
-endchoice
-
-config BR2_ROOTFS_DEVICE_TABLE
- string "Path to the permission tables"
- default "target/generic/device_table.txt"
- help
- Specify a space-separated list of permission table locations,
- that will be passed to the makedevs utility to assign
- correct owners and permissions on various files in the
- target filesystem.
-
- See package/makedevs/README for details on the usage and
- syntax of these files.
-
-config BR2_ROOTFS_STATIC_DEVICE_TABLE
- string "Path to the device tables"
- default "target/generic/device_table_dev.txt"
- depends on BR2_ROOTFS_DEVICE_CREATION_STATIC
- help
- Specify a space-separated list of device table locations,
- that will be passed to the makedevs utility to create all
- the special device files under /dev.
-
- See package/makedevs/README for details on the usage and
- syntax of these files.
-
-choice
- prompt "Root FS skeleton"
-
-config BR2_ROOTFS_SKELETON_DEFAULT
- bool "default target skeleton"
- help
- Use default target skeleton
-
-config BR2_ROOTFS_SKELETON_CUSTOM
- bool "custom target skeleton"
- help
- Use custom target skeleton.
-
-endchoice
-
-if BR2_ROOTFS_SKELETON_CUSTOM
-config BR2_ROOTFS_SKELETON_CUSTOM_PATH
- string "custom target skeleton path"
- default "fs/skeleton"
- help
- Path custom target skeleton.
-endif
-
-if BR2_ROOTFS_SKELETON_DEFAULT
-
-config BR2_TARGET_GENERIC_GETTY_PORT
- string "Port to run a getty (login prompt) on"
- default "ttyS0"
- help
- Specify a port to run a getty (login prompt) on.
-
-choice
- prompt "Baudrate to use"
- default BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200
- help
- Select a baudrate to use.
-
-config BR2_TARGET_GENERIC_GETTY_BAUDRATE_KEEP
- bool "keep kernel default"
-config BR2_TARGET_GENERIC_GETTY_BAUDRATE_9600
- bool "9600"
-config BR2_TARGET_GENERIC_GETTY_BAUDRATE_19200
- bool "19200"
-config BR2_TARGET_GENERIC_GETTY_BAUDRATE_38400
- bool "38400"
-config BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600
- bool "57600"
-config BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200
- bool "115200"
-endchoice
-
-config BR2_TARGET_GENERIC_GETTY_BAUDRATE
- string
- default "0" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_KEEP
- default "9600" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_9600
- default "19200" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_19200
- default "38400" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_38400
- default "57600" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_57600
- default "115200" if BR2_TARGET_GENERIC_GETTY_BAUDRATE_115200
-
-config BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW
- bool "remount root filesystem read-write during boot"
- default y
- help
- The root filesystem is typically mounted read-only at boot.
- By default, buildroot remounts it in read-write mode early during the
- boot process.
- Say no here if you would rather like your root filesystem to remain
- read-only.
- If unsure, say Y.
-
-endif # BR2_ROOTFS_SKELETON_DEFAULT
-
-config BR2_ROOTFS_POST_BUILD_SCRIPT
- string "Custom script to run before creating filesystem images"
- default ""
- help
- Specify a script to be run after the build has finished and before
- Buildroot starts packing the files into selected filesystem images.
-
- This gives users the oportunity to do board-specific cleanups,
- add-ons and the like, so the generated files can be used directly
- without further processing.
-
- The script is called with the target directory name as first and
- only argument. Make sure the exit code of that script is 0,
- otherwise make will stop after calling it.
-
-endmenu
diff --git a/target/generic/Makefile.in b/target/generic/Makefile.in
deleted file mode 100644
index 4185202b7..000000000
--- a/target/generic/Makefile.in
+++ /dev/null
@@ -1,53 +0,0 @@
-TARGET_GENERIC_HOSTNAME:=$(call qstrip,$(BR2_TARGET_GENERIC_HOSTNAME))
-TARGET_GENERIC_ISSUE:=$(call qstrip,$(BR2_TARGET_GENERIC_ISSUE))
-TARGET_GENERIC_GETTY:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
-TARGET_GENERIC_GETTY_BAUDRATE:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
-
-target-generic-hostname:
- mkdir -p $(TARGET_DIR)/etc
- echo "$(TARGET_GENERIC_HOSTNAME)" > $(TARGET_DIR)/etc/hostname
- $(SED) '$$a \127.0.1.1\t$(TARGET_GENERIC_HOSTNAME)' \
- -e '/^127.0.1.1/d' $(TARGET_DIR)/etc/hosts
-
-target-generic-issue:
- mkdir -p $(TARGET_DIR)/etc
- echo "$(TARGET_GENERIC_ISSUE)" > $(TARGET_DIR)/etc/issue
-
-target-generic-getty-busybox:
- $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(TARGET_GENERIC_GETTY)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
- $(TARGET_DIR)/etc/inittab
-
-# In sysvinit inittab, the "id" must not be longer than 4 bytes, so we
-# skip the "tty" part and keep only the remaining.
-target-generic-getty-sysvinit:
- $(SED) '/# GENERIC_SERIAL$$/s~^.*#~$(shell echo $(TARGET_GENERIC_GETTY) | tail -c+4)::respawn:/sbin/getty -L $(TARGET_GENERIC_GETTY) $(TARGET_GENERIC_GETTY_BAUDRATE) vt100 #~' \
- $(TARGET_DIR)/etc/inittab
-
-# Find commented line, if any, and remove leading '#'s
-target-generic-do-remount-rw:
- $(SED) '/^#.*# REMOUNT_ROOTFS_RW$$/s~^#\+~~' $(TARGET_DIR)/etc/inittab
-
-# Find uncommented line, if any, and add a leading '#'
-target-generic-dont-remount-rw:
- $(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
-
-ifneq ($(TARGET_GENERIC_HOSTNAME),)
-TARGETS += target-generic-hostname
-endif
-
-ifneq ($(TARGET_GENERIC_ISSUE),)
-TARGETS += target-generic-issue
-endif
-
-ifeq ($(BR2_ROOTFS_SKELETON_DEFAULT),y)
-ifeq ($(BR2_PACKAGE_SYSVINIT),y)
-TARGETS += target-generic-getty-sysvinit
-else
-TARGETS += target-generic-getty-busybox
-endif
-ifeq ($(BR2_TARGET_GENERIC_REMOUNT_ROOTFS_RW),y)
-TARGETS += target-generic-do-remount-rw
-else
-TARGETS += target-generic-dont-remount-rw
-endif
-endif
diff --git a/target/generic/device_table.txt b/target/generic/device_table.txt
deleted file mode 100644
index fc397a90c..000000000
--- a/target/generic/device_table.txt
+++ /dev/null
@@ -1,22 +0,0 @@
-# See package/makedevs/README for details
-#
-# This device table is used to assign proper ownership and permissions
-# on various files. It doesn't create any device file, as it is used
-# in both static device configurations (where /dev/ is static) and in
-# dynamic configurations (where devtmpfs, mdev or udev are used).
-#
-# <name> <type> <mode> <uid> <gid> <major> <minor> <start> <inc> <count>
-/dev d 755 0 0 - - - - -
-/tmp d 1777 0 0 - - - - -
-/etc d 755 0 0 - - - - -
-/home/default d 2755 1000 1000 - - - - -
-/etc/shadow f 600 0 0 - - - - -
-/etc/passwd f 644 0 0 - - - - -
-/etc/network/if-up.d d 755 0 0 - - - - -
-/etc/network/if-pre-up.d d 755 0 0 - - - - -
-/etc/network/if-post-up.d d 755 0 0 - - - - -
-/etc/network/if-down.d d 755 0 0 - - - - -
-/etc/network/if-pre-down.d d 755 0 0 - - - - -
-/etc/network/if-post-down.d d 755 0 0 - - - - -
-# uncomment this to allow starting x as non-root
-#/usr/X11R6/bin/Xfbdev f 4755 0 0 - - - - -
diff --git a/target/generic/device_table_dev.txt b/target/generic/device_table_dev.txt
deleted file mode 100644
index a93a2c808..000000000
--- a/target/generic/device_table_dev.txt
+++ /dev/null
@@ -1,146 +0,0 @@
-# See package/makedevs/README for details
-#
-# This device table is used only to create device files when a static
-# device configuration is used (entries in /dev are static).
-#
-# <name> <type> <mode> <uid> <gid> <major> <minor> <start> <inc> <count>
-
-# Normal system devices
-/dev/mem c 640 0 0 1 1 0 0 -
-/dev/kmem c 640 0 0 1 2 0 0 -
-/dev/null c 666 0 0 1 3 0 0 -
-/dev/zero c 666 0 0 1 5 0 0 -
-/dev/random c 666 0 0 1 8 0 0 -
-/dev/urandom c 666 0 0 1 9 0 0 -
-/dev/ram b 640 0 0 1 1 0 0 -
-/dev/ram b 640 0 0 1 0 0 1 4
-/dev/loop b 640 0 0 7 0 0 1 2
-/dev/rtc c 640 0 0 10 135 - - -
-/dev/console c 666 0 0 5 1 - - -
-/dev/tty c 666 0 0 5 0 - - -
-/dev/tty c 666 0 0 4 0 0 1 8
-/dev/ttyp c 666 0 0 3 0 0 1 10
-/dev/ptyp c 666 0 0 2 0 0 1 10
-/dev/ptmx c 666 0 0 5 2 - - -
-/dev/ttyP c 666 0 0 57 0 0 1 4
-/dev/ttyS c 666 0 0 4 64 0 1 4
-/dev/fb c 640 0 5 29 0 0 1 4
-#/dev/ttySA c 666 0 0 204 5 0 1 3
-/dev/psaux c 666 0 0 10 1 0 0 -
-#/dev/ppp c 666 0 0 108 0 - - -
-/dev/ttyAM c 666 0 0 204 16 0 1 3
-/dev/ttyCPM c 666 0 0 204 46 0 1 4
-/dev/ttyAMA c 666 0 0 204 64 0 1 4
-/dev/ttySAC c 666 0 0 204 64 0 1 4
-/dev/ttySC c 666 0 0 204 8 0 1 8
-/dev/ttyPSC c 666 0 0 204 148 0 1 4
-/dev/ttyUL c 666 0 0 204 187 0 1 4
-/dev/ttymxc c 666 0 0 207 16 0 1 3
-
-# Input stuff
-/dev/input d 755 0 0 - - - - -
-/dev/input/mice c 640 0 0 13 63 0 0 -
-/dev/input/mouse c 660 0 0 13 32 0 1 4
-/dev/input/event c 660 0 0 13 64 0 1 4
-#/dev/input/js c 660 0 0 13 0 0 1 4
-
-
-# MTD stuff
-/dev/mtd c 640 0 0 90 0 0 2 4
-/dev/mtdblock b 640 0 0 31 0 0 1 4
-
-#Tun/tap driver
-/dev/net d 755 0 0 - - - - -
-/dev/net/tun c 660 0 0 10 200 - - -
-
-# Audio stuff
-#/dev/audio c 666 0 29 14 4 - - -
-#/dev/audio1 c 666 0 29 14 20 - - -
-#/dev/dsp c 666 0 29 14 3 - - -
-#/dev/dsp1 c 666 0 29 14 19 - - -
-#/dev/sndstat c 666 0 29 14 6 - - -
-
-# User-mode Linux stuff
-#/dev/ubda b 640 0 0 98 0 0 0 -
-#/dev/ubda b 640 0 0 98 1 1 1 15
-
-# IDE Devices
-/dev/hda b 640 0 0 3 0 0 0 -
-/dev/hda b 640 0 0 3 1 1 1 15
-/dev/hdb b 640 0 0 3 64 0 0 -
-/dev/hdb b 640 0 0 3 65 1 1 15
-#/dev/hdc b 640 0 0 22 0 0 0 -
-#/dev/hdc b 640 0 0 22 1 1 1 15
-#/dev/hdd b 640 0 0 22 64 0 0 -
-#/dev/hdd b 640 0 0 22 65 1 1 15
-#/dev/hde b 640 0 0 33 0 0 0 -
-#/dev/hde b 640 0 0 33 1 1 1 15
-#/dev/hdf b 640 0 0 33 64 0 0 -
-#/dev/hdf b 640 0 0 33 65 1 1 15
-#/dev/hdg b 640 0 0 34 0 0 0 -
-#/dev/hdg b 640 0 0 34 1 1 1 15
-#/dev/hdh b 640 0 0 34 64 0 0 -
-#/dev/hdh b 640 0 0 34 65 1 1 15
-
-# SCSI Devices
-/dev/sda b 640 0 0 8 0 0 0 -
-/dev/sda b 640 0 0 8 1 1 1 15
-/dev/sdb b 640 0 0 8 16 0 0 -
-/dev/sdb b 640 0 0 8 17 1 1 15
-#/dev/sdc b 640 0 0 8 32 0 0 -
-#/dev/sdc b 640 0 0 8 33 1 1 15
-#/dev/sdd b 640 0 0 8 48 0 0 -
-#/dev/sdd b 640 0 0 8 49 1 1 15
-#/dev/sde b 640 0 0 8 64 0 0 -
-#/dev/sde b 640 0 0 8 65 1 1 15
-#/dev/sdf b 640 0 0 8 80 0 0 -
-#/dev/sdf b 640 0 0 8 81 1 1 15
-#/dev/sdg b 640 0 0 8 96 0 0 -
-#/dev/sdg b 640 0 0 8 97 1 1 15
-#/dev/sdh b 640 0 0 8 112 0 0 -
-#/dev/sdh b 640 0 0 8 113 1 1 15
-#/dev/sg c 640 0 0 21 0 0 1 15
-#/dev/scd b 640 0 0 11 0 0 1 15
-#/dev/st c 640 0 0 9 0 0 1 8
-#/dev/nst c 640 0 0 9 128 0 1 8
-#/dev/st c 640 0 0 9 32 1 1 4
-#/dev/st c 640 0 0 9 64 1 1 4
-#/dev/st c 640 0 0 9 96 1 1 4
-
-# USB block devices (ub driver)
-/dev/uba b 640 0 0 180 0 0 0 -
-/dev/uba b 640 0 0 180 1 1 1 6
-/dev/ubb b 640 0 0 180 8 0 0 -
-/dev/ubb b 640 0 0 180 65 1 1 6
-
-# Floppy disk devices
-#/dev/fd b 640 0 0 2 0 0 1 2
-#/dev/fd0d360 b 640 0 0 2 4 0 0 -
-#/dev/fd1d360 b 640 0 0 2 5 0 0 -
-#/dev/fd0h1200 b 640 0 0 2 8 0 0 -
-#/dev/fd1h1200 b 640 0 0 2 9 0 0 -
-#/dev/fd0u1440 b 640 0 0 2 28 0 0 -
-#/dev/fd1u1440 b 640 0 0 2 29 0 0 -
-#/dev/fd0u2880 b 640 0 0 2 32 0 0 -
-#/dev/fd1u2880 b 640 0 0 2 33 0 0 -
-
-# All the proprietary cdrom devices in the world
-#/dev/aztcd b 640 0 0 29 0 0 0 -
-#/dev/bpcd b 640 0 0 41 0 0 0 -
-#/dev/capi20 c 640 0 0 68 0 0 1 2
-#/dev/cdu31a b 640 0 0 15 0 0 0 -
-#/dev/cdu535 b 640 0 0 24 0 0 0 -
-#/dev/cm206cd b 640 0 0 32 0 0 0 -
-#/dev/sjcd b 640 0 0 18 0 0 0 -
-#/dev/sonycd b 640 0 0 15 0 0 0 -
-#/dev/gscd b 640 0 0 16 0 0 0 -
-#/dev/sbpcd b 640 0 0 25 0 0 0 -
-#/dev/sbpcd b 640 0 0 25 0 0 1 4
-#/dev/mcd b 640 0 0 23 0 0 0 -
-#/dev/optcd b 640 0 0 17 0 0 0 -
-
-# I2C device nodes
-/dev/i2c- c 666 0 0 89 0 0 1 4
-
-# v4l device nodes
-/dev/video c 666 0 0 81 0 0 1 4