summaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-30 12:37:16 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2007-07-30 12:37:16 +0000
commit59c867406df74b83450503da0d83056cfa0b7bf5 (patch)
tree5a16d3cd7d14d4f0b359df716e5a733c58a3c6d0 /target
parent9ac1a29d41a4b9e5193ffb928b1785da67249a65 (diff)
downloadbuildroot-novena-59c867406df74b83450503da0d83056cfa0b7bf5.tar.gz
buildroot-novena-59c867406df74b83450503da0d83056cfa0b7bf5.zip
- test if dir exists before trying to rmdir it.
Fixes failure due to non-existing usr/share dir on the target.
Diffstat (limited to 'target')
-rw-r--r--target/ext2/ext2root.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/ext2/ext2root.mk b/target/ext2/ext2root.mk
index 08a407eab..4ebb98142 100644
--- a/target/ext2/ext2root.mk
+++ b/target/ext2/ext2root.mk
@@ -91,7 +91,8 @@ $(EXT2_BASE): host-fakeroot makedevs genext2fs
@rm -rf $(TARGET_DIR)/usr/man
@rm -rf $(TARGET_DIR)/usr/share/man
@rm -rf $(TARGET_DIR)/usr/info
- @rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
+ @test -d $(TARGET_DIR)/usr/share && \
+ rmdir -p --ignore-fail-on-non-empty $(TARGET_DIR)/usr/share
-/sbin/ldconfig -r $(TARGET_DIR) 2>/dev/null
# Use fakeroot to pretend all target binaries are owned by root
rm -f $(STAGING_DIR)/_fakeroot.$(notdir $(EXT2_TARGET))