summaryrefslogtreecommitdiffstats
path: root/support/scripts
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-07-03 00:05:46 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-17 20:17:33 +0200
commitc98337911cc2427f9cf78e9da44a1b1dead61d4b (patch)
tree071259690fa9af2b30348b3cb46f7e22cece0e09 /support/scripts
parentd09967e0716894b91d27348877467ecba5eccad0 (diff)
downloadbuildroot-novena-c98337911cc2427f9cf78e9da44a1b1dead61d4b.tar.gz
buildroot-novena-c98337911cc2427f9cf78e9da44a1b1dead61d4b.zip
pkg-infra: add host-xxx-package macro
Create host-generic-package, host-autotools-package and host-cmake-package macros. Such a macro is more intuitive to use than the $(call ...,host) construct. Also it speeds things up by having one less $(call ...) evaluation. Also includes documentation update, but not for buildroot.html. This brings the time for 'make -qp' (which is used by bash-completion) down from 1.85s to 1.35s on my laptop. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'support/scripts')
-rwxr-xr-xsupport/scripts/pkg-stats12
1 files changed, 6 insertions, 6 deletions
diff --git a/support/scripts/pkg-stats b/support/scripts/pkg-stats
index 06d9d0de9..e7941bc18 100755
--- a/support/scripts/pkg-stats
+++ b/support/scripts/pkg-stats
@@ -100,27 +100,27 @@ for i in $(find package/ -name '*.mk') ; do
is_manual_target=0
is_manual_host=0
- if grep -E "\(call AUTOTARGETS,host\)" $i > /dev/null ; then
+ if grep -E "\(host-autotools-package\)" $i > /dev/null ; then
is_auto_host=1
fi
- if grep -E "\(call AUTOTARGETS\)" $i > /dev/null ; then
+ if grep -E "\(AUTOTARGETS\)" $i > /dev/null ; then
is_auto_target=1
fi
- if grep -E "\(call GENTARGETS,host\)" $i > /dev/null ; then
+ if grep -E "\(host-generic-package\)" $i > /dev/null ; then
is_pkg_host=1
fi
- if grep -E "\(call GENTARGETS\)" $i > /dev/null ; then
+ if grep -E "\(GENTARGETS\)" $i > /dev/null ; then
is_pkg_target=1
fi
- if grep -E "\(call CMAKETARGETS,host\)" $i > /dev/null ; then
+ if grep -E "\(host-cmake-package\)" $i > /dev/null ; then
is_cmake_host=1
fi
- if grep -E "\(call CMAKETARGETS\)" $i > /dev/null ; then
+ if grep -E "\(CMAKETARGETS\)" $i > /dev/null ; then
is_cmake_target=1
fi