summaryrefslogtreecommitdiffstats
path: root/support/kconfig/patches
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-04-04 11:24:24 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-11 09:30:39 +0200
commit6997e461fdb39985957d24d81e612113cf39e35c (patch)
tree096947e214caf457ffdb005522698f3e747ad08a /support/kconfig/patches
parentcfe70c5e13fcf6d99394c646c758236a79041653 (diff)
downloadbuildroot-novena-6997e461fdb39985957d24d81e612113cf39e35c.tar.gz
buildroot-novena-6997e461fdb39985957d24d81e612113cf39e35c.zip
support/kconfig: upgrade to 3.9-rc2
Our kconfig code is updated to the version of kernel 3.9-rc2. No major issues during the migration, except: * Some conflicts when applying 03-change-config-option-prefix.patch due to upstream kernel changes. * The need of adding a new patch, 15-fix-qconf-moc-rule.patch, to fix the make rule that generates the moc file for the Qt-based interface. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Tested-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'support/kconfig/patches')
-rw-r--r--support/kconfig/patches/01-kconfig-kernel-to-buildroot.patch32
-rw-r--r--support/kconfig/patches/02-cpp-comments-to-c-comments.patch30
-rw-r--r--support/kconfig/patches/03-change-config-option-prefix.patch174
-rw-r--r--support/kconfig/patches/06-br-build-system-integration.patch10
-rw-r--r--support/kconfig/patches/09-implement-kconfig-probability.patch10
-rw-r--r--support/kconfig/patches/10-br-build-system.patch8
-rw-r--r--support/kconfig/patches/11-use-mktemp-for-lxdialog.patch8
-rw-r--r--support/kconfig/patches/12-fix-glade-file-path.patch8
-rw-r--r--support/kconfig/patches/14-support-out-of-tree-config.patch38
-rw-r--r--support/kconfig/patches/15-fix-qconf-moc-rule.patch24
-rw-r--r--support/kconfig/patches/series1
11 files changed, 171 insertions, 172 deletions
diff --git a/support/kconfig/patches/01-kconfig-kernel-to-buildroot.patch b/support/kconfig/patches/01-kconfig-kernel-to-buildroot.patch
index ef3a05e43..f28131cf8 100644
--- a/support/kconfig/patches/01-kconfig-kernel-to-buildroot.patch
+++ b/support/kconfig/patches/01-kconfig-kernel-to-buildroot.patch
@@ -5,10 +5,10 @@
zconf.y | 2 +-
4 files changed, 5 insertions(+), 5 deletions(-)
-Index: config/gconf.glade
+Index: b/gconf.glade
===================================================================
---- config.orig/gconf.glade
-+++ config/gconf.glade
+--- a/gconf.glade
++++ b/gconf.glade
@@ -4,7 +4,7 @@
<widget class="GtkWindow" id="window1">
@@ -18,10 +18,10 @@ Index: config/gconf.glade
<property name="type">GTK_WINDOW_TOPLEVEL</property>
<property name="window_position">GTK_WIN_POS_NONE</property>
<property name="modal">False</property>
-Index: config/mconf.c
+Index: b/mconf.c
===================================================================
---- config.orig/mconf.c
-+++ config/mconf.c
+--- a/mconf.c
++++ b/mconf.c
@@ -178,9 +178,9 @@
"Arrow keys navigate the menu. "
"<Enter> selects submenus --->. "
@@ -34,29 +34,29 @@ Index: config/mconf.c
radiolist_instructions[] = N_(
"Use the arrow keys to navigate this window or "
"press the hotkey of the item you wish to select "
-Index: config/zconf.tab.c_shipped
+Index: b/zconf.tab.c_shipped
===================================================================
---- config.orig/zconf.tab.c_shipped
-+++ config/zconf.tab.c_shipped
-@@ -2256,7 +2256,7 @@
+--- a/zconf.tab.c_shipped
++++ b/zconf.tab.c_shipped
+@@ -2259,7 +2259,7 @@
modules_sym = sym_lookup(NULL, 0);
modules_sym->type = S_BOOLEAN;
modules_sym->flags |= SYMBOL_AUTO;
- rootmenu.prompt = menu_add_prompt(P_MENU, "Linux Kernel Configuration", NULL);
+ rootmenu.prompt = menu_add_prompt(P_MENU, "Buildroot Configuration", NULL);
- #if YYDEBUG
if (getenv("ZCONF_DEBUG"))
-Index: config/zconf.y
+ zconfdebug = 1;
+Index: b/zconf.y
===================================================================
---- config.orig/zconf.y
-+++ config/zconf.y
-@@ -501,7 +501,7 @@
+--- a/zconf.y
++++ b/zconf.y
+@@ -496,7 +496,7 @@
modules_sym = sym_lookup(NULL, 0);
modules_sym->type = S_BOOLEAN;
modules_sym->flags |= SYMBOL_AUTO;
- rootmenu.prompt = menu_add_prompt(P_MENU, "Linux Kernel Configuration", NULL);
+ rootmenu.prompt = menu_add_prompt(P_MENU, "Buildroot Configuration", NULL);
- #if YYDEBUG
if (getenv("ZCONF_DEBUG"))
+ zconfdebug = 1;
diff --git a/support/kconfig/patches/02-cpp-comments-to-c-comments.patch b/support/kconfig/patches/02-cpp-comments-to-c-comments.patch
index cb27056ad..72afa84ff 100644
--- a/support/kconfig/patches/02-cpp-comments-to-c-comments.patch
+++ b/support/kconfig/patches/02-cpp-comments-to-c-comments.patch
@@ -2,11 +2,11 @@
expr.c | 42 +++++++++++++++++++++---------------------
1 file changed, 21 insertions(+), 21 deletions(-)
-Index: config/expr.c
+Index: b/expr.c
===================================================================
---- config.orig/expr.c
-+++ config/expr.c
-@@ -331,7 +331,7 @@
+--- a/expr.c
++++ b/expr.c
+@@ -326,7 +326,7 @@
e->right.expr = expr_trans_bool(e->right.expr);
break;
case E_UNEQUAL:
@@ -15,7 +15,7 @@ Index: config/expr.c
if (e->left.sym->type == S_TRISTATE) {
if (e->right.sym == &symbol_no) {
e->type = E_SYMBOL;
-@@ -380,19 +380,19 @@
+@@ -375,19 +375,19 @@
if (e1->type == E_EQUAL && e2->type == E_EQUAL &&
((e1->right.sym == &symbol_yes && e2->right.sym == &symbol_mod) ||
(e1->right.sym == &symbol_mod && e2->right.sym == &symbol_yes))) {
@@ -38,7 +38,7 @@ Index: config/expr.c
return expr_alloc_comp(E_UNEQUAL, sym1, &symbol_yes);
}
}
-@@ -443,29 +443,29 @@
+@@ -438,29 +438,29 @@
if ((e1->type == E_SYMBOL && e2->type == E_EQUAL && e2->right.sym == &symbol_yes) ||
(e2->type == E_SYMBOL && e1->type == E_EQUAL && e1->right.sym == &symbol_yes))
@@ -73,7 +73,7 @@ Index: config/expr.c
sym2 = e2->right.sym;
if ((e1->right.sym->flags & SYMBOL_CONST) && (sym2->flags & SYMBOL_CONST))
return sym2 != e1->right.sym ? expr_alloc_comp(E_EQUAL, sym1, sym2)
-@@ -474,19 +474,19 @@
+@@ -469,19 +469,19 @@
if (e1->type == E_UNEQUAL && e2->type == E_UNEQUAL &&
((e1->right.sym == &symbol_yes && e2->right.sym == &symbol_no) ||
(e1->right.sym == &symbol_no && e2->right.sym == &symbol_yes)))
@@ -96,7 +96,7 @@ Index: config/expr.c
return expr_alloc_comp(E_EQUAL, sym1, &symbol_yes);
if ((e1->type == E_SYMBOL && e2->type == E_EQUAL && e2->right.sym == &symbol_mod) ||
-@@ -579,7 +579,7 @@
+@@ -574,7 +574,7 @@
switch (e1->type) {
case E_OR:
expr_eliminate_dups2(e1->type, &e1, &e1);
@@ -105,7 +105,7 @@ Index: config/expr.c
tmp1 = expr_transform(expr_alloc_one(E_NOT, expr_copy(e1)));
tmp2 = expr_copy(e2);
tmp = expr_extract_eq_and(&tmp1, &tmp2);
-@@ -594,7 +594,7 @@
+@@ -589,7 +589,7 @@
break;
case E_AND:
expr_eliminate_dups2(e1->type, &e1, &e1);
@@ -114,7 +114,7 @@ Index: config/expr.c
tmp1 = expr_transform(expr_alloc_one(E_NOT, expr_copy(e1)));
tmp2 = expr_copy(e2);
tmp = expr_extract_eq_or(&tmp1, &tmp2);
-@@ -703,7 +703,7 @@
+@@ -698,7 +698,7 @@
case E_NOT:
switch (e->left.expr->type) {
case E_NOT:
@@ -123,7 +123,7 @@ Index: config/expr.c
tmp = e->left.expr->left.expr;
free(e->left.expr);
free(e);
-@@ -712,14 +712,14 @@
+@@ -707,14 +707,14 @@
break;
case E_EQUAL:
case E_UNEQUAL:
@@ -140,7 +140,7 @@ Index: config/expr.c
tmp = e->left.expr;
e->type = E_AND;
e->right.expr = expr_alloc_one(E_NOT, tmp->right.expr);
-@@ -728,7 +728,7 @@
+@@ -723,7 +723,7 @@
e = expr_transform(e);
break;
case E_AND:
@@ -149,7 +149,7 @@ Index: config/expr.c
tmp = e->left.expr;
e->type = E_OR;
e->right.expr = expr_alloc_one(E_NOT, tmp->right.expr);
-@@ -738,7 +738,7 @@
+@@ -733,7 +733,7 @@
break;
case E_SYMBOL:
if (e->left.expr->left.sym == &symbol_yes) {
@@ -158,7 +158,7 @@ Index: config/expr.c
tmp = e->left.expr;
free(e);
e = tmp;
-@@ -747,7 +747,7 @@
+@@ -742,7 +742,7 @@
break;
}
if (e->left.expr->left.sym == &symbol_mod) {
@@ -167,7 +167,7 @@ Index: config/expr.c
tmp = e->left.expr;
free(e);
e = tmp;
-@@ -756,7 +756,7 @@
+@@ -751,7 +751,7 @@
break;
}
if (e->left.expr->left.sym == &symbol_no) {
diff --git a/support/kconfig/patches/03-change-config-option-prefix.patch b/support/kconfig/patches/03-change-config-option-prefix.patch
index 4c51eaa9b..0644ab0d3 100644
--- a/support/kconfig/patches/03-change-config-option-prefix.patch
+++ b/support/kconfig/patches/03-change-config-option-prefix.patch
@@ -4,18 +4,18 @@
menu.c | 2 +-
3 files changed, 31 insertions(+), 30 deletions(-)
-Index: kconfig/confdata.c
+Index: b/confdata.c
===================================================================
---- kconfig.orig/confdata.c
-+++ kconfig/confdata.c
-@@ -12,6 +12,7 @@
+--- a/confdata.c
++++ b/confdata.c
+@@ -13,6 +13,7 @@
#include <string.h>
#include <time.h>
#include <unistd.h>
+#include <libgen.h>
- #define LKC_DIRECT_LINK
#include "lkc.h"
+
@@ -25,7 +26,7 @@
static const char *conf_filename;
static int conf_lineno, conf_warnings, conf_unsaved;
@@ -34,7 +34,7 @@ Index: kconfig/confdata.c
return name ? name : ".config";
}
-@@ -249,20 +250,20 @@
+@@ -309,20 +310,20 @@
if (line[0] == '#') {
if (memcmp(line + 2, CONFIG_, strlen(CONFIG_)))
continue;
@@ -58,7 +58,7 @@ Index: kconfig/confdata.c
if (sym->type == S_UNKNOWN)
sym->type = S_BOOLEAN;
}
-@@ -278,8 +279,8 @@
+@@ -338,8 +339,8 @@
default:
;
}
@@ -69,7 +69,7 @@ Index: kconfig/confdata.c
if (!p)
continue;
*p++ = 0;
-@@ -290,13 +291,13 @@
+@@ -350,13 +351,13 @@
*p2 = 0;
}
if (def == S_DEF_USER) {
@@ -85,114 +85,88 @@ Index: kconfig/confdata.c
if (sym->type == S_UNKNOWN)
sym->type = S_OTHER;
}
-@@ -423,9 +424,9 @@
- {
- int l;
- if (headerfile)
-- fprintf(out, "#define %s%s \"", CONFIG_, name);
-+ fprintf(out, "#define %s \"", name);
- else
-- fprintf(out, "%s%s=\"", CONFIG_, name);
-+ fprintf(out, "%s=\"", name);
+@@ -484,8 +485,8 @@
+ bool skip_unset = (arg != NULL);
- while (1) {
- l = strcspn(str, "\"\\");
-@@ -450,14 +451,14 @@
- switch (sym_get_tristate_value(sym)) {
- case no:
- if (write_no)
-- fprintf(out, "# %s%s is not set\n",
+ if (!skip_unset)
+- fprintf(fp, "# %s%s is not set\n",
- CONFIG_, sym->name);
-+ fprintf(out, "# %s is not set\n",
++ fprintf(fp, "# %s is not set\n",
+ sym->name);
- break;
- case mod:
-- fprintf(out, "%s%s=m\n", CONFIG_, sym->name);
-+ fprintf(out, "%s=m\n", sym->name);
- break;
- case yes:
-- fprintf(out, "%s%s=y\n", CONFIG_, sym->name);
-+ fprintf(out, "%s=y\n", sym->name);
- break;
+ return;
}
break;
-@@ -467,7 +468,7 @@
- case S_HEX:
- case S_INT:
- str = sym_get_string_value(sym);
-- fprintf(out, "%s%s=%s\n", CONFIG_, sym->name, str);
-+ fprintf(out, "%s=%s\n", sym->name, str);
+@@ -493,7 +494,7 @@
break;
- case S_OTHER:
- case S_UNKNOWN:
-@@ -830,17 +831,17 @@
- case no:
- break;
- case mod:
-- fprintf(tristate, "%s%s=M\n",
-- CONFIG_, sym->name);
-- fprintf(out_h, "#define %s%s_MODULE 1\n",
-- CONFIG_, sym->name);
-+ fprintf(tristate, "%s=M\n",
-+ sym->name);
-+ fprintf(out_h, "#define %s_MODULE 1\n",
-+ sym->name);
- break;
- case yes:
- if (sym->type == S_TRISTATE)
-- fprintf(tristate,"%s%s=Y\n",
-- CONFIG_, sym->name);
-- fprintf(out_h, "#define %s%s 1\n",
-- CONFIG_, sym->name);
-+ fprintf(tristate,"%s=Y\n",
-+ sym->name);
-+ fprintf(out_h, "#define %s 1\n",
-+ sym->name);
- break;
- }
- break;
-@@ -850,14 +851,14 @@
- case S_HEX:
- str = sym_get_string_value(sym);
- if (str[0] != '0' || (str[1] != 'x' && str[1] != 'X')) {
-- fprintf(out_h, "#define %s%s 0x%s\n",
-- CONFIG_, sym->name, str);
-+ fprintf(out_h, "#define %s 0x%s\n",
-+ sym->name, str);
- break;
- }
- case S_INT:
- str = sym_get_string_value(sym);
-- fprintf(out_h, "#define %s%s %s\n",
-- CONFIG_, sym->name, str);
-+ fprintf(out_h, "#define %s %s\n",
-+ sym->name, str);
- break;
+ }
+
+- fprintf(fp, "%s%s=%s\n", CONFIG_, sym->name, value);
++ fprintf(fp, "%s=%s\n", sym->name, value);
+ }
+
+ static void
+@@ -543,8 +544,8 @@
+ suffix = "_MODULE";
+ /* fall through */
default:
- break;
-Index: kconfig/lkc.h
+- fprintf(fp, "#define %s%s%s 1\n",
+- CONFIG_, sym->name, suffix);
++ fprintf(fp, "#define %s%s 1\n",
++ sym->name, suffix);
+ }
+ break;
+ }
+@@ -553,14 +554,14 @@
+
+ if (value[0] != '0' || (value[1] != 'x' && value[1] != 'X'))
+ prefix = "0x";
+- fprintf(fp, "#define %s%s %s%s\n",
+- CONFIG_, sym->name, prefix, value);
++ fprintf(fp, "#define %s %s%s\n",
++ sym->name, prefix, value);
+ break;
+ }
+ case S_STRING:
+ case S_INT:
+- fprintf(fp, "#define %s%s %s\n",
+- CONFIG_, sym->name, value);
++ fprintf(fp, "#define %s %s\n",
++ sym->name, value);
+ break;
+ default:
+ break;
+@@ -606,7 +607,7 @@
+ {
+
+ if (sym->type == S_TRISTATE && *value != 'n')
+- fprintf(fp, "%s%s=%c\n", CONFIG_, sym->name, (char)toupper(*value));
++ fprintf(fp, "%s=%c\n", sym->name, (char)toupper(*value));
+ }
+
+ static struct conf_printer tristate_printer_cb =
+Index: b/lkc.h
===================================================================
---- kconfig.orig/lkc.h
-+++ kconfig/lkc.h
-@@ -42,7 +42,7 @@
+--- a/lkc.h
++++ b/lkc.h
+@@ -37,7 +37,7 @@
#define N_(text) (text)
#ifndef CONFIG_
-#define CONFIG_ "CONFIG_"
+#define CONFIG_ "BR2_"
#endif
-
- #define TF_COMMAND 0x0001
-Index: kconfig/menu.c
+ static inline const char *CONFIG_prefix(void)
+ {
+Index: b/menu.c
===================================================================
---- kconfig.orig/menu.c
-+++ kconfig/menu.c
-@@ -597,7 +597,7 @@
+--- a/menu.c
++++ b/menu.c
+@@ -635,7 +635,7 @@
if (menu_has_help(menu)) {
- if (sym->name) {
+ if (sym->name)
- str_printf(help, "%s%s:\n\n", CONFIG_, sym->name);
+ str_printf(help, "%s:\n\n", sym->name);
- str_append(help, _(menu_get_help(menu)));
- str_append(help, "\n");
- }
+ help_text = menu_get_help(menu);
+ }
+ str_printf(help, "%s\n", _(help_text));
diff --git a/support/kconfig/patches/06-br-build-system-integration.patch b/support/kconfig/patches/06-br-build-system-integration.patch
index feb166d36..3faa39ed6 100644
--- a/support/kconfig/patches/06-br-build-system-integration.patch
+++ b/support/kconfig/patches/06-br-build-system-integration.patch
@@ -2,11 +2,11 @@
Makefile | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
-Index: kconfig/Makefile
+Index: b/Makefile
===================================================================
---- kconfig.orig/Makefile
-+++ kconfig/Makefile
-@@ -175,11 +175,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -159,11 +159,11 @@
hostprogs-y := conf
@@ -20,7 +20,7 @@ Index: kconfig/Makefile
hostprogs-y += mconf
endif
-@@ -187,10 +187,10 @@
+@@ -171,10 +171,10 @@
hostprogs-y += kxgettext
endif
diff --git a/support/kconfig/patches/09-implement-kconfig-probability.patch b/support/kconfig/patches/09-implement-kconfig-probability.patch
index 3b6eb898f..72e2a254f 100644
--- a/support/kconfig/patches/09-implement-kconfig-probability.patch
+++ b/support/kconfig/patches/09-implement-kconfig-probability.patch
@@ -2,11 +2,11 @@
confdata.c | 22 +++++++++++++++++++---
1 file changed, 19 insertions(+), 3 deletions(-)
-Index: kconfig/confdata.c
+Index: b/confdata.c
===================================================================
---- kconfig.orig/confdata.c
-+++ kconfig/confdata.c
-@@ -982,7 +982,16 @@
+--- a/confdata.c
++++ b/confdata.c
+@@ -1107,7 +1107,16 @@
void conf_set_all_new_symbols(enum conf_def_mode mode)
{
struct symbol *sym, *csym;
@@ -24,7 +24,7 @@ Index: kconfig/confdata.c
for_all_symbols(i, sym) {
if (sym_has_value(sym))
-@@ -1001,8 +1010,15 @@
+@@ -1126,8 +1135,15 @@
sym->def[S_DEF_USER].tri = no;
break;
case def_random:
diff --git a/support/kconfig/patches/10-br-build-system.patch b/support/kconfig/patches/10-br-build-system.patch
index c5d9a7573..a877318e7 100644
--- a/support/kconfig/patches/10-br-build-system.patch
+++ b/support/kconfig/patches/10-br-build-system.patch
@@ -3,10 +3,10 @@
foo.h | 12 ++++++++++++
2 files changed, 65 insertions(+)
-Index: kconfig/Makefile.br
+Index: b/Makefile.br
===================================================================
--- /dev/null
-+++ kconfig/Makefile.br
++++ b/Makefile.br
@@ -0,0 +1,53 @@
+src := .
+top_srcdir=../../
@@ -61,10 +61,10 @@ Index: kconfig/Makefile.br
+
+FORCE:
+.PHONY: FORCE clean distclean
-Index: kconfig/foo.h
+Index: b/foo.h
===================================================================
--- /dev/null
-+++ kconfig/foo.h
++++ b/foo.h
@@ -0,0 +1,12 @@
+#ifndef __KCONFIG_FOO_H
+#define __KCONFIG_FOO_H
diff --git a/support/kconfig/patches/11-use-mktemp-for-lxdialog.patch b/support/kconfig/patches/11-use-mktemp-for-lxdialog.patch
index 21ca22883..1e0c80396 100644
--- a/support/kconfig/patches/11-use-mktemp-for-lxdialog.patch
+++ b/support/kconfig/patches/11-use-mktemp-for-lxdialog.patch
@@ -2,11 +2,11 @@
lxdialog/check-lxdialog.sh | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-Index: config/lxdialog/check-lxdialog.sh
+Index: b/lxdialog/check-lxdialog.sh
===================================================================
---- config.orig/lxdialog/check-lxdialog.sh
-+++ config/lxdialog/check-lxdialog.sh
-@@ -33,7 +33,7 @@
+--- a/lxdialog/check-lxdialog.sh
++++ b/lxdialog/check-lxdialog.sh
+@@ -34,7 +34,7 @@
}
# Temp file, try to clean up after us
diff --git a/support/kconfig/patches/12-fix-glade-file-path.patch b/support/kconfig/patches/12-fix-glade-file-path.patch
index badfc91d8..a5777da3e 100644
--- a/support/kconfig/patches/12-fix-glade-file-path.patch
+++ b/support/kconfig/patches/12-fix-glade-file-path.patch
@@ -2,11 +2,11 @@
gconf.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-Index: kconfig/gconf.c
+Index: b/gconf.c
===================================================================
---- kconfig.orig/gconf.c
-+++ kconfig/gconf.c
-@@ -1525,7 +1525,7 @@
+--- a/gconf.c
++++ b/gconf.c
+@@ -1486,7 +1486,7 @@
/* Determine GUI path */
env = getenv(SRCTREE);
if (env)
diff --git a/support/kconfig/patches/14-support-out-of-tree-config.patch b/support/kconfig/patches/14-support-out-of-tree-config.patch
index 8d76df2e6..318d0ddd9 100644
--- a/support/kconfig/patches/14-support-out-of-tree-config.patch
+++ b/support/kconfig/patches/14-support-out-of-tree-config.patch
@@ -4,11 +4,11 @@
util.c | 16 +++++++++++++--
3 files changed, 61 insertions(+), 18 deletions(-)
-Index: kconfig/conf.c
+Index: b/conf.c
===================================================================
---- kconfig.orig/conf.c
-+++ kconfig/conf.c
-@@ -503,7 +503,6 @@
+--- a/conf.c
++++ b/conf.c
+@@ -547,7 +547,6 @@
}
name = av[optind];
conf_parse(name);
@@ -16,10 +16,10 @@ Index: kconfig/conf.c
if (sync_kconfig) {
name = conf_get_configname();
if (stat(name, &tmpstat)) {
-Index: kconfig/confdata.c
+Index: b/confdata.c
===================================================================
---- kconfig.orig/confdata.c
-+++ kconfig/confdata.c
+--- a/confdata.c
++++ b/confdata.c
@@ -71,9 +71,7 @@
const char *conf_get_autoconfig_name(void)
@@ -31,7 +31,7 @@ Index: kconfig/confdata.c
}
static char *conf_expand_value(const char *in)
-@@ -563,6 +561,9 @@
+@@ -738,6 +736,9 @@
char dirname[PATH_MAX+1], tmpname[PATH_MAX+1], newname[PATH_MAX+1];
char *env;
@@ -41,7 +41,7 @@ Index: kconfig/confdata.c
dirname[0] = 0;
if (name && name[0]) {
struct stat st;
-@@ -661,6 +662,7 @@
+@@ -832,6 +833,7 @@
{
const char *name;
char path[PATH_MAX+1];
@@ -49,7 +49,7 @@ Index: kconfig/confdata.c
char *s, *d, c;
struct symbol *sym;
struct stat sb;
-@@ -669,8 +671,20 @@
+@@ -840,8 +842,20 @@
name = conf_get_autoconfig_name();
conf_read_simple(name, S_DEF_AUTO);
@@ -72,7 +72,7 @@ Index: kconfig/confdata.c
res = 0;
for_all_symbols(i, sym) {
-@@ -763,9 +777,11 @@
+@@ -934,9 +948,11 @@
close(fd);
}
out:
@@ -87,7 +87,7 @@ Index: kconfig/confdata.c
return res;
}
-@@ -776,25 +792,38 @@
+@@ -946,25 +962,38 @@
const char *name;
FILE *out, *tristate, *out_h;
int i;
@@ -130,7 +130,7 @@ Index: kconfig/confdata.c
if (!out_h) {
fclose(out);
fclose(tristate);
-@@ -871,19 +900,22 @@
+@@ -996,19 +1025,22 @@
name = getenv("KCONFIG_AUTOHEADER");
if (!name)
name = "include/generated/autoconf.h";
@@ -156,11 +156,11 @@ Index: kconfig/confdata.c
return 1;
return 0;
-Index: kconfig/util.c
+Index: b/util.c
===================================================================
---- kconfig.orig/util.c
-+++ kconfig/util.c
-@@ -32,6 +32,8 @@
+--- a/util.c
++++ b/util.c
+@@ -34,6 +34,8 @@
/* write a dependency file as used by kbuild to track dependencies */
int file_write_dep(const char *name)
{
@@ -169,7 +169,7 @@ Index: kconfig/util.c
struct symbol *sym, *env_sym;
struct expr *e;
struct file *file;
-@@ -39,7 +41,16 @@
+@@ -41,7 +43,16 @@
if (!name)
name = ".kconfig.d";
@@ -187,7 +187,7 @@ Index: kconfig/util.c
if (!out)
return 1;
fprintf(out, "deps_config := \\\n");
-@@ -70,7 +81,8 @@
+@@ -72,7 +83,8 @@
fprintf(out, "\n$(deps_config): ;\n");
fclose(out);
diff --git a/support/kconfig/patches/15-fix-qconf-moc-rule.patch b/support/kconfig/patches/15-fix-qconf-moc-rule.patch
new file mode 100644
index 000000000..eae978ebf
--- /dev/null
+++ b/support/kconfig/patches/15-fix-qconf-moc-rule.patch
@@ -0,0 +1,24 @@
+Fix the rule that generates the .moc file
+
+The Linux kernel has a "cmd" make function, but we don't have it in
+Buildroot, so we need to adjust this rule.
+
+Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -307,11 +307,8 @@
+
+ $(obj)/qconf.o: $(obj)/qconf.moc
+
+-quiet_cmd_moc = MOC $@
+- cmd_moc = $(KC_QT_MOC) -i $< -o $@
+-
+ $(obj)/%.moc: $(src)/%.h $(obj)/.tmp_qtcheck
+- $(call cmd,moc)
++ $(KC_QT_MOC) -i $< -o $@
+
+ # Extract gconf menu items for I18N support
+ $(obj)/gconf.glade.h: $(obj)/gconf.glade
diff --git a/support/kconfig/patches/series b/support/kconfig/patches/series
index 573911bdd..2d0e9919a 100644
--- a/support/kconfig/patches/series
+++ b/support/kconfig/patches/series
@@ -7,3 +7,4 @@
11-use-mktemp-for-lxdialog.patch
12-fix-glade-file-path.patch
14-support-out-of-tree-config.patch
+15-fix-qconf-moc-rule.patch