summaryrefslogtreecommitdiffstats
path: root/support/kconfig/Makefile.br
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-04-14 02:53:17 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-21 23:33:11 +0200
commitb58bf60b519353e983e372f5627d639e7cc72a7a (patch)
tree776ef1b941bce09441eca5a529faecde361836af /support/kconfig/Makefile.br
parent49f836380a5b110b583210f28781204e45982b86 (diff)
downloadbuildroot-novena-b58bf60b519353e983e372f5627d639e7cc72a7a.tar.gz
buildroot-novena-b58bf60b519353e983e372f5627d639e7cc72a7a.zip
support/kconfig: use kconfig-provided way of setting the CONFIG_ prefix
It's now been a while since it has been possible to build the kconfig parser to understand a prefix other than CONFIG_, and even no prefix at all, by setting the CONFIG_ macro (#define) at biuld time. Just use that, insted of patching, it will make it easier for us in the future. Our patches have been refreshed at the same time. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'support/kconfig/Makefile.br')
-rw-r--r--support/kconfig/Makefile.br2
1 files changed, 1 insertions, 1 deletions
diff --git a/support/kconfig/Makefile.br b/support/kconfig/Makefile.br
index 2f8b6ba92..41c5ce165 100644
--- a/support/kconfig/Makefile.br
+++ b/support/kconfig/Makefile.br
@@ -19,7 +19,7 @@ host-cxxmulti := $(foreach m,$(__hostprogs),\
host-cobjs := $(addprefix $(obj)/,$(sort $(foreach m,$(__hostprogs),$($(m)-objs))))
host-cxxobjs := $(addprefix $(obj)/,$(sort $(foreach m,$(__hostprogs),$($(m)-cxxobjs))))
-HOST_EXTRACFLAGS += -I$(obj)
+HOST_EXTRACFLAGS += -I$(obj) -DCONFIG_=\"\"
$(host-csingle): %: %.c
$(HOSTCC) $(HOST_EXTRACFLAGS) $(HOSTCFLAGS) $(HOSTCFLAGS_$@) $< -o $(obj)/$@