summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-15 00:45:27 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-15 11:51:05 +0100
commitea9ed43045851fda2f12e21d89800ffa643564a2 (patch)
tree6b7eaad6645e34288430b2cc51238ba41e413e6e /package
parent87dfeb10ad8aa0c52b20cd1baa05f7403656ca98 (diff)
downloadbuildroot-novena-ea9ed43045851fda2f12e21d89800ffa643564a2.tar.gz
buildroot-novena-ea9ed43045851fda2f12e21d89800ffa643564a2.zip
boost: slightly reduce the verbosity of the build
At the moment, the boost build is very verbose, it gives both the Jam-level command being executed, and the underlying system command being executed, with lots of newlines. Makes it hard to see where the failure is when there is one. So, we reduce the verbosity level to -d+1, which only gives the Jam-level command. So now, it looks like: common.copy /home/test/outputs/e/host/usr/aarch64-buildroot-linux-gnu/sysroot/usr/include/boost/geometry/multi/multi.hpp common.mkdir /home/test/outputs/e/host/usr/aarch64-buildroot-linux-gnu/sysroot/usr/include/boost/geometry/strategies gcc.compile.c++ bin.v2/libs/regex/build/gcc-4.7.3/release/threading-multi/icu.o gcc.compile.c++ bin.v2/libs/regex/build/gcc-4.7.3/release/threading-multi/regex_debug.o gcc.compile.c++ bin.v2/libs/regex/build/gcc-4.7.3/release/threading-multi/regex_raw_buffer.o Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/boost/boost.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/boost/boost.mk b/package/boost/boost.mk
index 62226ba22..5e1bb4e24 100644
--- a/package/boost/boost.mk
+++ b/package/boost/boost.mk
@@ -70,7 +70,7 @@ define BOOST_CONFIGURE_CMDS
endef
define BOOST_INSTALL_TARGET_CMDS
- (cd $(@D) && ./b2 -j$(PARALLEL_JOBS) -q -d+2 \
+ (cd $(@D) && ./b2 -j$(PARALLEL_JOBS) -q -d+1 \
--user-config=$(@D)/user-config.jam \
$(BOOST_OPT) \
--prefix=$(TARGET_DIR)/usr \
@@ -78,7 +78,7 @@ define BOOST_INSTALL_TARGET_CMDS
endef
define BOOST_INSTALL_STAGING_CMDS
- (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -d+2 \
+ (cd $(@D) && ./bjam -j$(PARALLEL_JOBS) -d+1 \
--user-config=$(@D)/user-config.jam \
$(BOOST_OPT) \
--prefix=$(STAGING_DIR)/usr \