summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-07-03 13:20:35 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-03 13:20:35 +0200
commitddd0db77ab2d2f9a2cf60304b773507a563da6c5 (patch)
tree085437c8866a1fb2dbcaa8c5c6c6e0b8b2ccfe69 /package
parent8ae604912bbe506e617d12bf8db3db9cb04d14ab (diff)
parenta1125b31af64bb3fbe40b7db2be0e70f4c2471bb (diff)
downloadbuildroot-novena-ddd0db77ab2d2f9a2cf60304b773507a563da6c5.tar.gz
buildroot-novena-ddd0db77ab2d2f9a2cf60304b773507a563da6c5.zip
Merge branch 'qtopia-fixes' of git://git.busybox.net/~tpetazzoni/git/buildroot
Diffstat (limited to 'package')
-rw-r--r--package/qtopia4/qtopia-4.5.2-fix-qt-zlib-build.patch20
-rw-r--r--package/qtopia4/qtopia4.mk4
2 files changed, 23 insertions, 1 deletions
diff --git a/package/qtopia4/qtopia-4.5.2-fix-qt-zlib-build.patch b/package/qtopia4/qtopia-4.5.2-fix-qt-zlib-build.patch
new file mode 100644
index 000000000..b191cc751
--- /dev/null
+++ b/package/qtopia4/qtopia-4.5.2-fix-qt-zlib-build.patch
@@ -0,0 +1,20 @@
+When QT is compiled in qt-zlib mode, compilation of
+src/gui/painting/qprintengine_pdf.cpp fails because zlib.h is not
+found. The following patch adds the internal QT zlib directory to the
+include path to fix this issue.
+
+---
+ src/gui/painting/painting.pri | 3 +++
+ 1 file changed, 3 insertions(+)
+
+Index: qt-embedded-linux-opensource-src-4.5.2/src/gui/painting/painting.pri
+===================================================================
+--- qt-embedded-linux-opensource-src-4.5.2.orig/src/gui/painting/painting.pri
++++ qt-embedded-linux-opensource-src-4.5.2/src/gui/painting/painting.pri
+@@ -367,3 +367,6 @@
+ SOURCES += painting/qwindowsurface_d3d.cpp
+ }
+
++contains(QT_CONFIG, zlib) {
++ INCLUDEPATH += ../3rdparty/zlib
++}
diff --git a/package/qtopia4/qtopia4.mk b/package/qtopia4/qtopia4.mk
index 42825194d..fc95da48a 100644
--- a/package/qtopia4/qtopia4.mk
+++ b/package/qtopia4/qtopia4.mk
@@ -21,7 +21,7 @@
# x86 crosscompiling under linux x86. Please remove it when the workaround
# is no longer necessary.
-QTOPIA4_VERSION:=4.5.1
+QTOPIA4_VERSION:=4.5.2
QTOPIA4_CAT:=$(BZCAT)
BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME:=$(strip $(subst ",, $(BR2_PACKAGE_QTOPIA4_COMMERCIAL_USERNAME)))
@@ -440,6 +440,8 @@ endif
$(call QTOPIA4_QMAKE_SET,OBJCOPY,$(TARGET_OBJCOPY))
$(call QTOPIA4_QMAKE_SET,RANLIB,$(TARGET_RANLIB))
$(call QTOPIA4_QMAKE_SET,STRIP,$(TARGET_STRIP))
+ $(call QTOPIA4_QMAKE_SET,CFLAGS,$(TARGET_CFLAGS))
+ $(call QTOPIA4_QMAKE_SET,CXXFLAGS,$(TARGET_CXXFLAGS))
-[ -f $(QTOPIA4_QCONFIG_FILE) ] && cp $(QTOPIA4_QCONFIG_FILE) \
$(QTOPIA4_TARGET_DIR)/$(QTOPIA4_QCONFIG_FILE_LOCATION)
# Qt doesn't use PKG_CONFIG, it searches for pkg-config with 'which'.