summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2006-09-26 12:48:43 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2006-09-26 12:48:43 +0000
commitdd510c2b699dbe5cc3b6440b6e12505fe214e6bc (patch)
tree67c06676c56bba8c3104eddcfd90f11114ddf535 /package
parent990fee63fc614fbf9810b286baad88b2d3f8c324 (diff)
downloadbuildroot-novena-dd510c2b699dbe5cc3b6440b6e12505fe214e6bc.tar.gz
buildroot-novena-dd510c2b699dbe5cc3b6440b6e12505fe214e6bc.zip
Proper !i386 cross compilation support
Diffstat (limited to 'package')
-rw-r--r--package/xorg/xorg-config.patch23
-rw-r--r--package/xorg/xorg.mk22
2 files changed, 42 insertions, 3 deletions
diff --git a/package/xorg/xorg-config.patch b/package/xorg/xorg-config.patch
index 580362cd5..8f6861d8a 100644
--- a/package/xorg/xorg-config.patch
+++ b/package/xorg/xorg-config.patch
@@ -47,7 +47,7 @@
+#define XInputDrivers mouse keyboard
--- xc/config/cf/cross.def~ Thu May 12 15:28:01 MDT 2005
+++ xc/config/cf/cross.def Thu May 12 15:28:01 MDT 2005
-@@ -1,45 +1,45 @@
+@@ -1,45 +1,63 @@
-/* $XFree86: xc/config/cf/cross.def,v 1.1 2000/12/08 22:09:34 keithp Exp $ */
+/* $XFree86: xc/config/cf/cross.def,v 1.2 2001/03/30 02:15:17 keithp Exp $ */
/*
@@ -57,10 +57,27 @@
* given your local configuration.
*/
-#if 0
--#undef i386Architecture
-+#define i386Architecture
++/* Undefine any architectures detected */
+ #undef i386Architecture
-#define Arm32Architecture
++#undef AMD64Architecture
++#undef PpcArchitecture
++#undef SparcArchitecture
++#undef AlphaArchitecture
+#undef Arm32Architecture
++#undef ia64Architecture
++#undef MipsArchitecture
++
++/* Cross compiling for: */
++#define REPLACE_XORG_ARCHArchitecture
++
++/* MTRR detection in linux.cf is exec'ed before cross.def, so redo it here */
++#undef HasMTRRSupport
++#if defined (i386Architecture) || defined (AMD64Architecture)
++# define HasMTRRSupport YES
++#else
++# define HasMTRRSupport NO /* no for non-ix86 */
++#endif
#undef OptimizedCDebugFlags
-#define OptimizedCDebugFlags -O2
diff --git a/package/xorg/xorg.mk b/package/xorg/xorg.mk
index eeb911a8b..15a590796 100644
--- a/package/xorg/xorg.mk
+++ b/package/xorg/xorg.mk
@@ -48,6 +48,27 @@ else
HAS_FREETYPE2=NO
endif
+# figure out Xorg's idea of corresponding architecture name
+ifeq ($(BR2_alpha),y)
+XARCH=Alpha
+else ifeq ($(BR2_arm),y)
+XARCH=Arm32
+else ifeq ($(BR2_armeb),y)
+XARCH=Arm32
+else ifeq ($(BR2_i386),y)
+XARCH=i386A
+else ifeq ($(BR2_mips),y)
+XARCH=Mips
+else ifeq ($(BR2_mipsel),y)
+XARCH=Mips
+else ifeq ($(BR2_powerpc),y)
+XARCH=Ppc
+else ifeq ($(BR2_sparc),y)
+XARCH=Sparc
+else ifeq ($(BR2_x86_64),y)
+XARCH=AMD64
+endif
+
$(DL_DIR)/$(XORG_SOURCE):
$(WGET) -P $(DL_DIR) $(XORG_SITE)/$(XORG_SOURCE)
@@ -65,6 +86,7 @@ $(XORG_DIR)/.configured: $(DL_DIR)/$(XORG_SOURCE)
$(SED) 's:#.*define.*HasPam.*YES::g' $(XORG_DIR)/config/cf/linux.cf
$(SED) 's:#.*define.*CrossCompiling.*NO:#define CrossCompiling YES:g' $(XORG_DIR)/config/cf/Imake.tmpl
$(SED) 's:#.*undef.*CrossCompileDir.*:#define CrossCompileDir$(STAGING_DIR)/bin:g' $(XORG_DIR)/config/cf/Imake.tmpl
+ $(SED) 's:REPLACE_XORG_ARCH:$(XARCH):g' $(XORG_DIR)/config/cf/cross.def
touch $(XORG_DIR)/.configured
$(XORG_XSERVER): $(XORG_DIR)/.configured