summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>2012-07-14 22:31:19 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-07-15 12:36:23 +0200
commitcbf1691ef48f8a87587713f981054c9fef22e2c4 (patch)
treebf8779cd7e2857541aae82d17f812dca448cbce5 /package
parent99dd58418daee463074d7fd38d6ea98aca97d304 (diff)
downloadbuildroot-novena-cbf1691ef48f8a87587713f981054c9fef22e2c4.tar.gz
buildroot-novena-cbf1691ef48f8a87587713f981054c9fef22e2c4.zip
pkg-infra: remove self-dependency from host packages
When HOST_XXX_DEPENDENCIES are derived automatically from XXX_DEPENDENCIES, a self-dependency is created if host-xxx is a dependency of xxx. This was the case for miniperl. Filter out the self-dependency. Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package')
-rw-r--r--package/pkg-autotargets.mk2
-rw-r--r--package/pkg-cmaketargets.mk2
-rw-r--r--package/pkg-gentargets.mk2
3 files changed, 3 insertions, 3 deletions
diff --git a/package/pkg-autotargets.mk b/package/pkg-autotargets.mk
index c9887c2e1..d31230dd7 100644
--- a/package/pkg-autotargets.mk
+++ b/package/pkg-autotargets.mk
@@ -201,7 +201,7 @@ endef
# This must be repeated from GENTARGETS_INNER, otherwise we get an empty
# _DEPENDENCIES if _AUTORECONF is YES. Also filter the result of _AUTORECONF
# away from the non-host rule
-$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool,\
+$(2)_DEPENDENCIES ?= $(filter-out host-automake host-autoconf host-libtool $(1),\
$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
diff --git a/package/pkg-cmaketargets.mk b/package/pkg-cmaketargets.mk
index 371ab11c7..b405df505 100644
--- a/package/pkg-cmaketargets.mk
+++ b/package/pkg-cmaketargets.mk
@@ -98,7 +98,7 @@ endif
# This must be repeated from GENTARGETS_INNER, otherwise we only get
# host-cmake in _DEPENDENCIES because of the following line
-$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+$(2)_DEPENDENCIES ?= $(filter-out $(1),$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
$(2)_DEPENDENCIES += host-cmake
diff --git a/package/pkg-gentargets.mk b/package/pkg-gentargets.mk
index 1c9b45807..5da9cdc70 100644
--- a/package/pkg-gentargets.mk
+++ b/package/pkg-gentargets.mk
@@ -245,7 +245,7 @@ $(2)_OVERRIDE_SRCDIR = $($(2)_SITE)
endif
endif
-$(2)_DEPENDENCIES ?= $(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES)))
+$(2)_DEPENDENCIES ?= $(filter-out $(1),$(patsubst host-host-%,host-%,$(addprefix host-,$($(3)_DEPENDENCIES))))
$(2)_INSTALL_STAGING ?= NO
$(2)_INSTALL_IMAGES ?= NO