summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2008-02-28 02:13:42 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2008-02-28 02:13:42 +0000
commitbebbe792df26f355f82da8d7508f719f56a8a559 (patch)
tree0fb2714dffe92e06f25dd96db8c01d2139576a8c /package
parent49609366cfac5fa5a6347068fb61c8a61f85c034 (diff)
downloadbuildroot-novena-bebbe792df26f355f82da8d7508f719f56a8a559.tar.gz
buildroot-novena-bebbe792df26f355f82da8d7508f719f56a8a559.zip
Make sure 'linkage.h' headers are installed. Add hack to bootstrap newer
versions of GCC. Filter out 'gnu99' from assembly flags. Use the 'headers' target instead of 'pregen' to prepare for more NPTL integration. Fix broken MTD package configuration....someone believes in the Klingon release process apparently. Fix build issues with netplug and libpng. Fix source path for microcom as original site no longer exists.
Diffstat (limited to 'package')
-rw-r--r--package/libpng/remove-setjmp-error.patch17
-rw-r--r--package/microcom/microcom.mk2
-rw-r--r--package/mtd/Config.in4
-rw-r--r--package/netplug/netplug-getsockname-cast.patch12
4 files changed, 32 insertions, 3 deletions
diff --git a/package/libpng/remove-setjmp-error.patch b/package/libpng/remove-setjmp-error.patch
new file mode 100644
index 000000000..19df516d2
--- /dev/null
+++ b/package/libpng/remove-setjmp-error.patch
@@ -0,0 +1,17 @@
+diff -ur libpng-1.2.16/pngconf.h libpng-1.2.16-patched/pngconf.h
+--- libpng-1.2.16/pngconf.h 2007-01-31 07:22:33.000000000 -0600
++++ libpng-1.2.16-patched/pngconf.h 2008-02-27 17:40:23.707516659 -0600
+@@ -310,13 +310,6 @@
+ # define PNG_SAVE_BSD_SOURCE
+ # undef _BSD_SOURCE
+ # endif
+-# ifdef _SETJMP_H
+- /* If you encounter a compiler error here, see the explanation
+- * near the end of INSTALL.
+- */
+- __png.h__ already includes setjmp.h;
+- __dont__ include it again.;
+-# endif
+ # endif /* __linux__ */
+
+ /* include setjmp.h for error handling */
diff --git a/package/microcom/microcom.mk b/package/microcom/microcom.mk
index b19053643..db74bc1d1 100644
--- a/package/microcom/microcom.mk
+++ b/package/microcom/microcom.mk
@@ -26,7 +26,7 @@
# TARGETS
# http://microcom.port5.com/m102.tar.gz
MICROCOM_VERSION:=1.02
-MICROCOM_SITE:=http://microcom.port5.com/
+MICROCOM_SITE:=http://buildroot.uclibc.org/downloads/buildroot-sources/
MICROCOM_SOURCE:=m102.tar.gz
MICROCOM_DIR:=$(BUILD_DIR)/microcom-$(MICROCOM_VERSION)
diff --git a/package/mtd/Config.in b/package/mtd/Config.in
index d35758b90..39bf8422c 100644
--- a/package/mtd/Config.in
+++ b/package/mtd/Config.in
@@ -46,9 +46,9 @@ config BR2_PACKAGE_MTD_SNAPSHOT_STRING
config BR2_PACKAGE_MTD_ORIG_STRING
string
- depends on BR2_PACKAGE_MTD_ORIG
+ depends on BR2_PACKAGE_MTD
default "mtd-utils-1.1.0.tar.bz2" if BR2_PACKAGE_MTD_UTILS
- default "mtd_20061007.orig.tar.gz" if BR2_PACKAGE_MTD_20050122
+ default "mtd_20061007.orig.tar.gz" if BR2_PACKAGE_MTD_20061007
default "mtd_20050122.orig.tar.gz" if BR2_PACKAGE_MTD_20050122
default $(BR2_PACKAGE_MTD_SNAPSHOT_STRING) if BR2_PACKAGE_MTD_SNAPSHOT
diff --git a/package/netplug/netplug-getsockname-cast.patch b/package/netplug/netplug-getsockname-cast.patch
new file mode 100644
index 000000000..c8e38e6f9
--- /dev/null
+++ b/package/netplug/netplug-getsockname-cast.patch
@@ -0,0 +1,12 @@
+diff -ur netplug-1.2.9/netlink.c netplug-1.2.9-patched/netlink.c
+--- netplug-1.2.9/netlink.c 2005-01-07 23:57:09.000000000 -0600
++++ netplug-1.2.9-patched/netlink.c 2008-02-27 17:59:48.373864047 -0600
+@@ -286,7 +286,7 @@
+
+ int addr_len = sizeof(addr);
+
+- if (getsockname(fd, (struct sockaddr *) &addr, &addr_len) == -1) {
++ if (getsockname(fd, (struct sockaddr *) &addr, (socklen_t *) &addr_len) == -1) {
+ do_log(LOG_ERR, "Could not get socket details: %m");
+ exit(1);
+ }