summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-11 14:15:16 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-11 14:15:16 +0000
commit9c8f05848743961363b10eb9f247f19c57145c0a (patch)
treeefd303f86e1ffc61115b99573073f2df6ccf2c54 /package
parent71f799e085f1f271f5c37c0fd563101a3bbcacc7 (diff)
downloadbuildroot-novena-9c8f05848743961363b10eb9f247f19c57145c0a.tar.gz
buildroot-novena-9c8f05848743961363b10eb9f247f19c57145c0a.zip
move ver number into a var
Diffstat (limited to 'package')
-rw-r--r--package/wtools/wtools.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/package/wtools/wtools.mk b/package/wtools/wtools.mk
index 447fe6fbf..497a1083a 100644
--- a/package/wtools/wtools.mk
+++ b/package/wtools/wtools.mk
@@ -3,10 +3,10 @@
# wtools - Wireless Tools
#
#############################################################
-#
-WTOOLS_SOURCE_URL=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
-WTOOLS_SOURCE=wireless_tools.26.tar.gz
-WTOOLS_BUILD_DIR=$(BUILD_DIR)/wireless_tools.26
+WTOOLS_VER:=26
+WTOOLS_SOURCE_URL:=http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux
+WTOOLS_SOURCE:=wireless_tools.$(WTOOLS_VER).tar.gz
+WTOOLS_BUILD_DIR=$(BUILD_DIR)/wireless_tools.$(WTOOLS_VER)
$(DL_DIR)/$(WTOOLS_SOURCE):
$(WGET) -P $(DL_DIR) $(WTOOLS_SOURCE_URL)/$(WTOOLS_SOURCE)
@@ -31,11 +31,11 @@ $(TARGET_DIR)/sbin/iwconfig: $(WTOOLS_BUILD_DIR)/iwconfig
cp -af $(WTOOLS_BUILD_DIR)/iwlist $(TARGET_DIR)/sbin/
cp -af $(WTOOLS_BUILD_DIR)/iwpriv $(TARGET_DIR)/sbin/
cp -af $(WTOOLS_BUILD_DIR)/iwspy $(TARGET_DIR)/sbin/
- cp -af $(WTOOLS_BUILD_DIR)/libiw.so.26 $(TARGET_DIR)/lib
+ cp -af $(WTOOLS_BUILD_DIR)/libiw.so.$(WTOOLS_VER) $(TARGET_DIR)/lib
$(STRIP) $(TARGET_DIR)/sbin/iwconfig $(TARGET_DIR)/sbin/iwevent \
$(TARGET_DIR)/sbin/iwgetid $(TARGET_DIR)/sbin/iwlist \
$(TARGET_DIR)/sbin/iwpriv $(TARGET_DIR)/sbin/iwspy \
- $(TARGET_DIR)/lib/libiw.so.26
+ $(TARGET_DIR)/lib/libiw.so.$(WTOOLS_VER)
wtools: $(TARGET_DIR)/sbin/iwconfig