summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2011-07-14 09:27:32 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-07-24 22:42:22 +0200
commit9683d4f11aa39975d8ed006b86f7fda4f59876c6 (patch)
tree655a4407f3046bb6e1fbfa4c152594f627fd6157 /package
parentcae6d2397bfb49cda38d5ba629e049a959eede8a (diff)
downloadbuildroot-novena-9683d4f11aa39975d8ed006b86f7fda4f59876c6.tar.gz
buildroot-novena-9683d4f11aa39975d8ed006b86f7fda4f59876c6.zip
gst-plugins-good: update configuration options
Update the list of plugins that can be selected/deselected. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/multimedia/gst-plugins-good/Config.in9
-rw-r--r--package/multimedia/gst-plugins-good/gst-plugins-good.mk18
2 files changed, 27 insertions, 0 deletions
diff --git a/package/multimedia/gst-plugins-good/Config.in b/package/multimedia/gst-plugins-good/Config.in
index 368642f6c..b43160366 100644
--- a/package/multimedia/gst-plugins-good/Config.in
+++ b/package/multimedia/gst-plugins-good/Config.in
@@ -82,6 +82,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ID3DEMUX
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ICYDEMUX
bool "icydemux"
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_IMAGEFREEZE
+ bool "imagefreeze"
+
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_INTERLEAVE
bool "interleave"
@@ -127,6 +130,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTPMANAGER
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_RTSP
bool "rtsp"
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SHAPEWIPE
+ bool "shapewipe"
+
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SMPTE
bool "smpte"
@@ -180,6 +186,9 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_FLAC
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS
bool "ossaudio (OSS audio)"
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS4
+ bool "oss4 (Open Sound System 4)"
+
config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC
bool "souphttpsrc (http client)"
select BR2_PACKAGE_LIBSOUP
diff --git a/package/multimedia/gst-plugins-good/gst-plugins-good.mk b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
index 8fbd120a9..ff7b4c0c8 100644
--- a/package/multimedia/gst-plugins-good/gst-plugins-good.mk
+++ b/package/multimedia/gst-plugins-good/gst-plugins-good.mk
@@ -144,6 +144,12 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-icydemux
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_IMAGEFREEZE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-imagefreeze
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-imagefreeze
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_INTERLEAVE),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-interleave
else
@@ -234,6 +240,12 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-rtsp
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SHAPEWIPE),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-shapewipe
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-shapewipe
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SMPTE),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-smpte
else
@@ -321,6 +333,12 @@ else
GST_PLUGINS_GOOD_CONF_OPT += --disable-oss
endif
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS4),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-oss4
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-oss4
+endif
+
ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_SOUPHTTPSRC),y)
GST_PLUGINS_GOOD_CONF_OPT += --enable-soup
GST_PLUGINS_GOOD_DEPENDENCIES += libsoup