summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJohn Voltz <john.voltz@gmail.com>2008-03-21 17:56:00 +0000
committerJohn Voltz <john.voltz@gmail.com>2008-03-21 17:56:00 +0000
commit69ae3cec84e6dbd19b8501e13f84d7159074ab75 (patch)
treedc80fa7ee5e88a0aa365e06a7a9f2edc2966e2ca /package
parent577cec7bc6d6a1c2b914d0061cdc3cd2ac03e7f3 (diff)
downloadbuildroot-novena-69ae3cec84e6dbd19b8501e13f84d7159074ab75.tar.gz
buildroot-novena-69ae3cec84e6dbd19b8501e13f84d7159074ab75.zip
confusing busybox config option description patch, busybox can be built as shared libs, hardlinks ... etc. rename to full install. Patch from Nigel Kukard
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Config.in8
-rw-r--r--package/busybox/busybox.mk2
2 files changed, 5 insertions, 5 deletions
diff --git a/package/busybox/Config.in b/package/busybox/Config.in
index daf33d265..5ea1c277c 100644
--- a/package/busybox/Config.in
+++ b/package/busybox/Config.in
@@ -49,13 +49,13 @@ config BR2_BUSYBOX_VERSION
default "1.9.2" if BR2_BUSYBOX_VERSION_1_9_X
-config BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS
- bool "Install symlinks for BusyBox applets"
+config BR2_PACKAGE_BUSYBOX_FULLINSTALL
+ bool "Run BusyBox's own full installation"
depends BR2_PACKAGE_BUSYBOX
default y
help
- If you want to automatically install symlinks for all the
- supported applets to the busybox binary, then answer Y.
+ If you want to run BusyBox's own full install for the
+ configured applets, then answer Y.
This may overwrite files from other packages if your
busybox includes replacement applets for the package.
diff --git a/package/busybox/busybox.mk b/package/busybox/busybox.mk
index 80e26b590..c616e451d 100644
--- a/package/busybox/busybox.mk
+++ b/package/busybox/busybox.mk
@@ -112,7 +112,7 @@ ifeq ($(BR2_PREFER_IMA)$(BR2_PACKAGE_BUSYBOX_SNAPSHOT),yy)
endif
$(TARGET_DIR)/bin/busybox: $(BUSYBOX_DIR)/busybox
-ifeq ($(BR2_PACKAGE_BUSYBOX_INSTALL_SYMLINKS),y)
+ifeq ($(BR2_PACKAGE_BUSYBOX_FULLINSTALL),y)
$(MAKE) CC=$(TARGET_CC) CROSS_COMPILE="$(TARGET_CROSS)" \
CROSS="$(TARGET_CROSS)" PREFIX="$(TARGET_DIR)" \
ARCH=$(KERNEL_ARCH) \