summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorHamish Moffatt <hamish@cloud.net.au>2008-06-13 10:01:03 +0000
committerHamish Moffatt <hamish@cloud.net.au>2008-06-13 10:01:03 +0000
commit40cee2a9fc1ffef65a39519554e4579a180c4530 (patch)
tree5add7ab4c177d3e91d195e037493926f557d43e1 /package
parentc498d3f9f3fdcb9decdffd9c4661f6a61d057514 (diff)
downloadbuildroot-novena-40cee2a9fc1ffef65a39519554e4579a180c4530.tar.gz
buildroot-novena-40cee2a9fc1ffef65a39519554e4579a180c4530.zip
Publish $(LIBTOOL) variable and use it in the libusb dependencies, so that
libusb isn't rebuilt every time.
Diffstat (limited to 'package')
-rw-r--r--package/libtool/libtool.mk5
-rw-r--r--package/libusb/libusb.mk2
2 files changed, 4 insertions, 3 deletions
diff --git a/package/libtool/libtool.mk b/package/libtool/libtool.mk
index fc97a3136..20b300a8d 100644
--- a/package/libtool/libtool.mk
+++ b/package/libtool/libtool.mk
@@ -12,6 +12,7 @@ LIBTOOL_DIR:=$(BUILD_DIR)/libtool-$(LIBTOOL_VERSION)
LIBTOOL_HOST_DIR:=$(TOOL_BUILD_DIR)/libtool-$(LIBTOOL_VERSION)-host
LIBTOOL_BINARY:=libtool
LIBTOOL_TARGET_BINARY:=usr/bin/libtool
+LIBTOOL:=$(STAGING_DIR)/usr/bin/libtool
$(DL_DIR)/$(LIBTOOL_SOURCE):
$(WGET) -P $(DL_DIR) $(LIBTOOL_SITE)/$(LIBTOOL_SOURCE)
@@ -122,7 +123,7 @@ $(LIBTOOL_HOST_DIR)/$(LIBTOOL_BINARY): $(LIBTOOL_HOST_DIR)/.configured
$(MAKE) -C $(LIBTOOL_HOST_DIR)
touch -c $@
-$(STAGING_DIR)/$(LIBTOOL_TARGET_BINARY): $(LIBTOOL_HOST_DIR)/$(LIBTOOL_BINARY)
+$(LIBTOOL): $(LIBTOOL_HOST_DIR)/$(LIBTOOL_BINARY)
$(MAKE) -C $(LIBTOOL_HOST_DIR) install
rm -rf $(STAGING_DIR)/share/locale
rm -rf $(STAGING_DIR)/usr/share/doc
@@ -134,7 +135,7 @@ ifneq ($(BR2_HAVE_MANPAGES),y)
endif
touch -c $@
-host-libtool: $(STAGING_DIR)/$(LIBTOOL_TARGET_BINARY)
+host-libtool: $(LIBTOOL)
host-libtool-clean:
$(MAKE) -C $(LIBTOOL_HOST_DIR) uninstall
diff --git a/package/libusb/libusb.mk b/package/libusb/libusb.mk
index c707b0a0c..adb8b9232 100644
--- a/package/libusb/libusb.mk
+++ b/package/libusb/libusb.mk
@@ -24,7 +24,7 @@ $(DL_DIR)/$(LIBUSB_SOURCE): $(LIBUSB_PATCH)
libusb-source: $(DL_DIR)/$(LIBUSB_SOURCE) $(LIBUSB_PATCH)
libusb-unpacked: $(LIBUSB_DIR)/.unpacked
-$(LIBUSB_DIR)/.unpacked: $(AUTOCONF) $(AUTOMAKE) $(STAGING_DIR)/$(LIBTOOL_TARGET_BINARY) $(DL_DIR)/$(LIBUSB_SOURCE)
+$(LIBUSB_DIR)/.unpacked: $(AUTOCONF) $(AUTOMAKE) $(LIBTOOL) $(DL_DIR)/$(LIBUSB_SOURCE)
$(LIBUSB_CAT) $(DL_DIR)/$(LIBUSB_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
ifneq ($(LIBUSB_PATCH_FILE),)
(cd $(LIBUSB_DIR) && $(LIBUSB_CAT) $(LIBUSB_PATCH) | patch -p1)