summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorYann E. MORIN <yann.morin.1998@free.fr>2013-04-12 07:14:18 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-04-25 22:56:42 +0200
commit1f3af04db77f9e9e707bd37ee85f6508aef797f2 (patch)
treed697d2aa29aaa71c77f9e3186e6d98cb697fc21b /package
parent74bdc4b9ddf6d4d2ecdd238715dcbf14292b8829 (diff)
downloadbuildroot-novena-1f3af04db77f9e9e707bd37ee85f6508aef797f2.tar.gz
buildroot-novena-1f3af04db77f9e9e707bd37ee85f6508aef797f2.zip
packages: add ability for packages to create users
Packages that install daemons may need those daemons to run as a non-root, or an otherwise non-system (eg. 'daemon'), user. Add infrastructure for packages to create users, by declaring the FOO_USERS variable that contain a makedev-syntax-like description of the user(s) to add. Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Cc: Samuel Martin <s.martin49@gmail.com> Cc: Cam Hutchison <camh@xdna.net> Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package')
-rw-r--r--package/pkg-generic.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/pkg-generic.mk b/package/pkg-generic.mk
index e6bc95599..b55b5f0b4 100644
--- a/package/pkg-generic.mk
+++ b/package/pkg-generic.mk
@@ -529,6 +529,7 @@ ifeq ($$($$($(2)_KCONFIG_VAR)),y)
TARGETS += $(1)
PACKAGES_PERMISSIONS_TABLE += $$($(2)_PERMISSIONS)$$(sep)
PACKAGES_DEVICES_TABLE += $$($(2)_DEVICES)$$(sep)
+PACKAGES_USERS += $$($(2)_USERS)$$(sep)
ifeq ($$($(2)_SITE_METHOD),svn)
DL_TOOLS_DEPENDENCIES += svn