summaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorPaul Jones <paul@pauljones.id.au>2010-06-07 22:33:06 +1000
committerPeter Korsgaard <jacmet@sunsite.dk>2010-07-27 23:52:58 +0200
commitd47c73ee9ba3ab9a5f6a113047e3a4aae1afd278 (patch)
tree5d482a4373dfe451444e2783010c900ceb63aeca /package/zlib
parenta563a663471ed1e3a8344b27255850e7c7094a23 (diff)
downloadbuildroot-novena-d47c73ee9ba3ab9a5f6a113047e3a4aae1afd278.tar.gz
buildroot-novena-d47c73ee9ba3ab9a5f6a113047e3a4aae1afd278.zip
zlib: Bump to 1.2.5
Closes #1981 Signed-off-by: Paul Jones <paul@pauljones.id.au> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/zlib-1.2.1-configure.patch103
-rw-r--r--package/zlib/zlib-arflags.patch21
-rw-r--r--package/zlib/zlib.mk3
3 files changed, 1 insertions, 126 deletions
diff --git a/package/zlib/zlib-1.2.1-configure.patch b/package/zlib/zlib-1.2.1-configure.patch
deleted file mode 100644
index ccd67caa3..000000000
--- a/package/zlib/zlib-1.2.1-configure.patch
+++ /dev/null
@@ -1,103 +0,0 @@
---- zlib/configure
-+++ zlib/configure
-@@ -160,8 +160,8 @@
- if test $shared -eq 1; then
- echo Checking for shared library support...
- # we must test in two steps (cc then ld), required at least on SunOS 4.x
-- if test "`($CC -c $SFLAGS $test.c) 2>&1`" = "" &&
-- test "`($LDSHARED -o $test$shared_ext $test.o) 2>&1`" = ""; then
-+ if ($CC -c $SFLAGS $test.c) 2>>config.log &&
-+ ($LDSHARED -o $test$shared_ext $test.o) 2>>config.log; then
- CFLAGS="$SFLAGS"
- LIBS="$LIBS $SHAREDLIBV"
- echo Building shared library $SHAREDLIBV with $CC.
-@@ -185,7 +185,7 @@
- #include <unistd.h>
- int main() { return 0; }
- EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- sed < zconf.in.h "/HAVE_UNISTD_H/s%0%1%" > zconf.h
- echo "Checking for unistd.h... Yes."
- else
-@@ -208,7 +208,7 @@
- }
- EOF
-
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- echo "Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf()"
-
- cat > $test.c <<EOF
-@@ -232,7 +232,7 @@
- }
- EOF
-
-- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
-+ if ($CC $CFLAGS -o $test $test.c) 2>>config.log; then
- echo "Checking for vsnprintf() in stdio.h... Yes."
-
- cat >$test.c <<EOF
-@@ -257,7 +257,7 @@
- }
- EOF
-
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- echo "Checking for return value of vsnprintf()... Yes."
- else
- CFLAGS="$CFLAGS -DHAS_vsnprintf_void"
-@@ -295,7 +295,7 @@
- }
- EOF
-
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- echo "Checking for return value of vsprintf()... Yes."
- else
- CFLAGS="$CFLAGS -DHAS_vsprintf_void"
-@@ -325,7 +325,7 @@
- }
- EOF
-
-- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
-+ if ($CC $CFLAGS -o $test $test.c) 2>>config.log; then
- echo "Checking for snprintf() in stdio.h... Yes."
-
- cat >$test.c <<EOF
-@@ -344,7 +344,7 @@
- }
- EOF
-
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- echo "Checking for return value of snprintf()... Yes."
- else
- CFLAGS="$CFLAGS -DHAS_snprintf_void"
-@@ -376,7 +376,7 @@
- }
- EOF
-
-- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- echo "Checking for return value of sprintf()... Yes."
- else
- CFLAGS="$CFLAGS -DHAS_sprintf_void"
-@@ -392,7 +392,7 @@
- #include <errno.h>
- int main() { return 0; }
- EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- echo "Checking for errno.h... Yes."
- else
- echo "Checking for errno.h... No."
-@@ -407,7 +407,7 @@
- return mmap((caddr_t)0, (off_t)0, PROT_READ, MAP_SHARED, 0, (off_t)0);
- }
- EOF
--if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
-+if ($CC -c $CFLAGS $test.c) 2>>config.log; then
- CFLAGS="$CFLAGS -DUSE_MMAP"
- echo Checking for mmap support... Yes.
- else
diff --git a/package/zlib/zlib-arflags.patch b/package/zlib/zlib-arflags.patch
deleted file mode 100644
index f9dae52be..000000000
--- a/package/zlib/zlib-arflags.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- zlib-1.2.3/Makefile.in
-+++ zlib-1.2.3/Makefile.in
-@@ -33,7 +33,8 @@
- SHAREDLIBV=libz.so.1.2.3
- SHAREDLIBM=libz.so.1
-
--AR=ar rc
-+AR=ar
-+ARFLAGS=rc
- RANLIB=ranlib
- TAR=tar
- SHELL=/bin/sh
-@@ -68,7 +69,7 @@
- fi
-
- libz.a: $(OBJS) $(OBJA)
-- $(AR) $@ $(OBJS) $(OBJA)
-+ $(AR) $(ARFLAGS) $@ $(OBJS) $(OBJA)
- -@ ($(RANLIB) $@ || true) >/dev/null 2>&1
-
- match.o: match.S
diff --git a/package/zlib/zlib.mk b/package/zlib/zlib.mk
index 3144ae9fa..ad5eda7ad 100644
--- a/package/zlib/zlib.mk
+++ b/package/zlib/zlib.mk
@@ -3,7 +3,7 @@
# zlib
#
#############################################################
-ZLIB_VERSION:=1.2.3
+ZLIB_VERSION:=1.2.5
ZLIB_SOURCE:=zlib-$(ZLIB_VERSION).tar.bz2
ZLIB_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/libpng
ZLIB_INSTALL_STAGING=YES
@@ -24,7 +24,6 @@ define ZLIB_CONFIGURE_CMDS
./configure \
$(ZLIB_SHARED) \
--prefix=/usr \
- --exec-prefix=$(STAGING_DIR)/usr/bin \
--libdir=$(STAGING_DIR)/usr/lib \
--includedir=$(STAGING_DIR)/usr/include \
)