summaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
author"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
committer"Steven J. Hill" <sjhill@realitydiluted.com>2007-07-06 04:26:32 +0000
commit9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6 (patch)
tree3f0ef80e7c44f59eae59c0fdfb9b56882d454112 /package/zlib
parent9fba54740004859fd7e0936cda64d01c2b48633b (diff)
downloadbuildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.tar.gz
buildroot-novena-9a4ca08e5ffee842d0ede78c4ce9f745f0ca42b6.zip
Remove usage of TARGET_LDFLAGS all together. Both TARGET_CFLAGS and TARGET_LDFLAGS are passed with the compilers and linker respectively so that we can pass CFLAGS and LDFLAGS on a per-package basis which was not possible previously and a number of packages failed to build. TARGET_CFLAGS usage in package makefiles will be removed next.
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/zlib.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/zlib/zlib.mk b/package/zlib/zlib.mk
index 4414b68c7..8456274ea 100644
--- a/package/zlib/zlib.mk
+++ b/package/zlib/zlib.mk
@@ -8,7 +8,7 @@ ZLIB_SOURCE:=zlib-$(ZLIB_VER).tar.bz2
ZLIB_CAT:=$(BZCAT)
ZLIB_SITE:=http://$(BR2_SOURCEFORGE_MIRROR).dl.sourceforge.net/sourceforge/libpng
ZLIB_DIR:=$(BUILD_DIR)/zlib-$(ZLIB_VER)
-ZLIB_CFLAGS:=$(TARGET_CFLAGS) -fPIC
+ZLIB_CFLAGS:=-fPIC
ifeq ($(BR2_LARGEFILE),y)
ZLIB_CFLAGS+=-D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
endif
@@ -25,8 +25,7 @@ $(ZLIB_DIR)/.patched: $(DL_DIR)/$(ZLIB_SOURCE)
$(ZLIB_DIR)/.configured: $(ZLIB_DIR)/.patched
(cd $(ZLIB_DIR); rm -rf config.cache ; \
$(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS) $(ZLIB_CFLAGS)" \
- LDFLAGS="$(TARGET_LDFLAGS)" \
+ CFLAGS="$(ZLIB_CFLAGS)" \
./configure \
--shared \
--prefix=/usr \