summaryrefslogtreecommitdiffstats
path: root/package/zlib
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-08-30 22:45:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-08-30 22:45:08 +0000
commit02a28380e9bc05df9e6c1a595b187d19f65e4921 (patch)
treeda1fdd345f6c8f8265eb0de130d9152745be63d5 /package/zlib
parent34f82af799172a02319b010f5c952d4ad24f7dfe (diff)
downloadbuildroot-novena-02a28380e9bc05df9e6c1a595b187d19f65e4921.tar.gz
buildroot-novena-02a28380e9bc05df9e6c1a595b187d19f65e4921.zip
some patches from Gentoo
Diffstat (limited to 'package/zlib')
-rw-r--r--package/zlib/zlib-1.2.1-configure.patch103
-rw-r--r--package/zlib/zlib-arflags.patch21
2 files changed, 124 insertions, 0 deletions
diff --git a/package/zlib/zlib-1.2.1-configure.patch b/package/zlib/zlib-1.2.1-configure.patch
new file mode 100644
index 000000000..ccd67caa3
--- /dev/null
+++ b/package/zlib/zlib-1.2.1-configure.patch
@@ -0,0 +1,103 @@
+--- zlib/configure
++++ zlib/configure
+@@ -160,8 +160,8 @@
+ if test $shared -eq 1; then
+ echo Checking for shared library support...
+ # we must test in two steps (cc then ld), required at least on SunOS 4.x
+- if test "`($CC -c $SFLAGS $test.c) 2>&1`" = "" &&
+- test "`($LDSHARED -o $test$shared_ext $test.o) 2>&1`" = ""; then
++ if ($CC -c $SFLAGS $test.c) 2>>config.log &&
++ ($LDSHARED -o $test$shared_ext $test.o) 2>>config.log; then
+ CFLAGS="$SFLAGS"
+ LIBS="$LIBS $SHAREDLIBV"
+ echo Building shared library $SHAREDLIBV with $CC.
+@@ -185,7 +185,7 @@
+ #include <unistd.h>
+ int main() { return 0; }
+ EOF
+-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ sed < zconf.in.h "/HAVE_UNISTD_H/s%0%1%" > zconf.h
+ echo "Checking for unistd.h... Yes."
+ else
+@@ -208,7 +208,7 @@
+ }
+ EOF
+
+-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ echo "Checking whether to use vs[n]printf() or s[n]printf()... using vs[n]printf()"
+
+ cat > $test.c <<EOF
+@@ -232,7 +232,7 @@
+ }
+ EOF
+
+- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
++ if ($CC $CFLAGS -o $test $test.c) 2>>config.log; then
+ echo "Checking for vsnprintf() in stdio.h... Yes."
+
+ cat >$test.c <<EOF
+@@ -257,7 +257,7 @@
+ }
+ EOF
+
+- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ echo "Checking for return value of vsnprintf()... Yes."
+ else
+ CFLAGS="$CFLAGS -DHAS_vsnprintf_void"
+@@ -295,7 +295,7 @@
+ }
+ EOF
+
+- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ echo "Checking for return value of vsprintf()... Yes."
+ else
+ CFLAGS="$CFLAGS -DHAS_vsprintf_void"
+@@ -325,7 +325,7 @@
+ }
+ EOF
+
+- if test "`($CC $CFLAGS -o $test $test.c) 2>&1`" = ""; then
++ if ($CC $CFLAGS -o $test $test.c) 2>>config.log; then
+ echo "Checking for snprintf() in stdio.h... Yes."
+
+ cat >$test.c <<EOF
+@@ -344,7 +344,7 @@
+ }
+ EOF
+
+- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ echo "Checking for return value of snprintf()... Yes."
+ else
+ CFLAGS="$CFLAGS -DHAS_snprintf_void"
+@@ -376,7 +376,7 @@
+ }
+ EOF
+
+- if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++ if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ echo "Checking for return value of sprintf()... Yes."
+ else
+ CFLAGS="$CFLAGS -DHAS_sprintf_void"
+@@ -392,7 +392,7 @@
+ #include <errno.h>
+ int main() { return 0; }
+ EOF
+-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ echo "Checking for errno.h... Yes."
+ else
+ echo "Checking for errno.h... No."
+@@ -407,7 +407,7 @@
+ return mmap((caddr_t)0, (off_t)0, PROT_READ, MAP_SHARED, 0, (off_t)0);
+ }
+ EOF
+-if test "`($CC -c $CFLAGS $test.c) 2>&1`" = ""; then
++if ($CC -c $CFLAGS $test.c) 2>>config.log; then
+ CFLAGS="$CFLAGS -DUSE_MMAP"
+ echo Checking for mmap support... Yes.
+ else
diff --git a/package/zlib/zlib-arflags.patch b/package/zlib/zlib-arflags.patch
new file mode 100644
index 000000000..f9dae52be
--- /dev/null
+++ b/package/zlib/zlib-arflags.patch
@@ -0,0 +1,21 @@
+--- zlib-1.2.3/Makefile.in
++++ zlib-1.2.3/Makefile.in
+@@ -33,7 +33,8 @@
+ SHAREDLIBV=libz.so.1.2.3
+ SHAREDLIBM=libz.so.1
+
+-AR=ar rc
++AR=ar
++ARFLAGS=rc
+ RANLIB=ranlib
+ TAR=tar
+ SHELL=/bin/sh
+@@ -68,7 +69,7 @@
+ fi
+
+ libz.a: $(OBJS) $(OBJA)
+- $(AR) $@ $(OBJS) $(OBJA)
++ $(AR) $(ARFLAGS) $@ $(OBJS) $(OBJA)
+ -@ ($(RANLIB) $@ || true) >/dev/null 2>&1
+
+ match.o: match.S