summaryrefslogtreecommitdiffstats
path: root/package/zeromq
diff options
context:
space:
mode:
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>2012-03-14 17:38:16 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2012-03-15 11:42:30 +0100
commit06211219a06c795d2c5d4352a1637a4d60f881ba (patch)
treeb851140b66c96ae3eb853fb0b9c3476342dffe77 /package/zeromq
parent5c3cb0ba00282ba2b7a16efdbb4fce96c29a6e3a (diff)
downloadbuildroot-novena-06211219a06c795d2c5d4352a1637a4d60f881ba.tar.gz
buildroot-novena-06211219a06c795d2c5d4352a1637a4d60f881ba.zip
new package: zeromq
[Peter: fix C++/LF deps, reformat help, install into staging] Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/zeromq')
-rw-r--r--package/zeromq/Config.in25
-rw-r--r--package/zeromq/zeromq.mk12
2 files changed, 37 insertions, 0 deletions
diff --git a/package/zeromq/Config.in b/package/zeromq/Config.in
new file mode 100644
index 000000000..e1d3d520b
--- /dev/null
+++ b/package/zeromq/Config.in
@@ -0,0 +1,25 @@
+comment "zeromq requires a toolchain with C++, LARGEFILE + WCHAR support"
+ depends on !(BR2_INSTALL_LIBSTDCPP && BR2_LARGEFILE && BR2_USE_WCHAR)
+
+config BR2_PACKAGE_ZEROMQ
+ bool "zeromq"
+ depends on BR2_INSTALL_LIBSTDCPP
+ depends on BR2_LARGEFILE # util-linux
+ depends on BR2_USE_WCHAR # util-linux
+ select BR2_PACKAGE_UTIL_LINUX
+ select BR2_PACKAGE_UTIL_LINUX_LIBUUID
+ help
+ ØMQ (ZeroMQ, 0MQ, zmq) looks like an embeddable networking
+ library but acts like a concurrency framework. It gives you
+ sockets that carry whole messages across various transports
+ like in-process, inter- process, TCP, and multicast. You can
+ connect sockets N-to-N with patterns like fanout, pub-sub,
+ task distribution, and request-reply. It's fast enough to
+ be the fabric for clustered products. Its asynchronous I/O
+ model gives you scalable multicore applications, built as
+ asynchronous message-processing tasks. It has a score of
+ language APIs and runs on most operating systems.
+
+ ØMQ is from iMatix and is LGPL open source.
+
+ http://www.zeromq.org/
diff --git a/package/zeromq/zeromq.mk b/package/zeromq/zeromq.mk
new file mode 100644
index 000000000..b6c499d18
--- /dev/null
+++ b/package/zeromq/zeromq.mk
@@ -0,0 +1,12 @@
+#############################################################
+#
+# zeromq
+#
+#############################################################
+
+ZEROMQ_VERSION = 2.1.11
+ZEROMQ_SITE = http://download.zeromq.org/
+ZEROMQ_INSTALL_STAGING = YES
+ZEROMQ_DEPENDENCIES = util-linux
+
+$(eval $(call AUTOTARGETS))