summaryrefslogtreecommitdiffstats
path: root/package/yasm/yasm.mk
diff options
context:
space:
mode:
authorStefan Froberg <stefan.froberg@petroprogram.com>2012-08-10 22:30:11 +0300
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2012-08-11 22:27:03 +0200
commit6a81db89eb036216c87b3036251adbeea2013b0e (patch)
tree239807bdb72ee3ebdfdf33debfdf5d06f921e9cc /package/yasm/yasm.mk
parent04be7f0f8ca100afaf06b264332bc2cd61fbb3d0 (diff)
downloadbuildroot-novena-6a81db89eb036216c87b3036251adbeea2013b0e.tar.gz
buildroot-novena-6a81db89eb036216c87b3036251adbeea2013b0e.zip
yasm: New package
[thomas.petazzoni@free-electrons.com: drop the --disable-static from configuration options, the default behavior should work without problem. make sure the pre configure hook is also executed for the host variant of the package. add the project upstream URL in the package help text ] Signed-off-by: Stefan Froberg <stefan.froberg@petroprogram.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/yasm/yasm.mk')
-rw-r--r--package/yasm/yasm.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/yasm/yasm.mk b/package/yasm/yasm.mk
new file mode 100644
index 000000000..ac75d2b6a
--- /dev/null
+++ b/package/yasm/yasm.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# yasm
+#
+#############################################################
+YASM_VERSION = 1.2.0
+YASM_SOURCE = yasm-$(YASM_VERSION).tar.gz
+YASM_SITE = http://www.tortall.net/projects/yasm/releases/
+YASM_CONF_OPT = --disable-static
+
+define YASM_PRE_CONFIGURE_FIXUP
+# This sed prevents it compiling 2 programs (vsyasm and ytasm)
+# that are only of use on Microsoft Windows.
+ sed -i 's#) ytasm.*#)#' $(@D)/Makefile.in
+endef
+
+YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))