summaryrefslogtreecommitdiffstats
path: root/package/yajl
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-06-22 17:08:55 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-06-22 17:08:55 +0200
commit489692fcde8477ac7b949d32a424bded815b360c (patch)
treedd2f9d85f65f7c56d8079052d20137ec036b9514 /package/yajl
parente8c46b118b011c766511c44fa9232e074ad6bcbc (diff)
downloadbuildroot-novena-489692fcde8477ac7b949d32a424bded815b360c.tar.gz
buildroot-novena-489692fcde8477ac7b949d32a424bded815b360c.zip
yajl: fix link issue on uClibc
We need to link with -lm for isnan() / isinf(). Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/yajl')
-rw-r--r--package/yajl/yajl-2.0.2-math-link.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/yajl/yajl-2.0.2-math-link.patch b/package/yajl/yajl-2.0.2-math-link.patch
new file mode 100644
index 000000000..355a24856
--- /dev/null
+++ b/package/yajl/yajl-2.0.2-math-link.patch
@@ -0,0 +1,24 @@
+[PATCH] fix json_reformat linking on uClibc
+
+json_reformat calls yajl_gen_* functions, which internally use isnan() /
+isinf(). On Glibc, these are provided by libc, but on uClibc you need to
+link with -lm (like the spec says), so ensure we do so.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ reformatter/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: yajl-2.0.2/reformatter/CMakeLists.txt
+===================================================================
+--- yajl-2.0.2.orig/reformatter/CMakeLists.txt
++++ yajl-2.0.2/reformatter/CMakeLists.txt
+@@ -26,7 +26,7 @@
+
+ ADD_EXECUTABLE(json_reformat ${SRCS})
+
+-TARGET_LINK_LIBRARIES(json_reformat yajl_s)
++TARGET_LINK_LIBRARIES(json_reformat yajl_s m)
+
+ # copy the binary into the output directory
+ GET_TARGET_PROPERTY(binPath json_reformat LOCATION)