summaryrefslogtreecommitdiffstats
path: root/package/xinetd
diff options
context:
space:
mode:
authorDanomi Manchego <danomimanchego123@gmail.com>2012-06-18 15:01:44 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-06-23 21:39:09 +0200
commit2d177d4852ec5549f93671273f07ba60dbabdcc2 (patch)
treedbb369266bc46c27ab893bbcf95f298cf7619769 /package/xinetd
parent3f487ef72845965b578002b2f9c0a37eff47e97a (diff)
downloadbuildroot-novena-2d177d4852ec5549f93671273f07ba60dbabdcc2.tar.gz
buildroot-novena-2d177d4852ec5549f93671273f07ba60dbabdcc2.zip
xinetd: expand DESTDIR patch to fix uninstall target
Expand the openWRT patch to fix xinetd's "uninstall" target, so that buildroot's "xinetd-clean" removes the correct files. Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/xinetd')
-rw-r--r--package/xinetd/xinetd-2.3.15/002-destdir.patch28
1 files changed, 24 insertions, 4 deletions
diff --git a/package/xinetd/xinetd-2.3.15/002-destdir.patch b/package/xinetd/xinetd-2.3.15/002-destdir.patch
index 15ff4b8dc..7a323eb68 100644
--- a/package/xinetd/xinetd-2.3.15/002-destdir.patch
+++ b/package/xinetd/xinetd-2.3.15/002-destdir.patch
@@ -1,14 +1,15 @@
This patch adds $(DESTDIR) to xinetd's installation paths, to support
installation to a cross-compiled RFS area.
-The content of this patch was copied from the OpenWrt project:
+The content of this patch was inspired by the OpenWrt project:
https://dev.openwrt.org/browser/packages/net/xinetd/patches/002-destdir.patch
Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -75,15 +75,15 @@ dlibxlog: dlibsio dlibstr
+diff -urN xinetd-2.3.15.ORIG/Makefile.in xinetd-2.3.15/Makefile.in
+--- xinetd-2.3.15.ORIG/Makefile.in 2007-09-20 13:01:52.000000000 -0400
++++ xinetd-2.3.15/Makefile.in 2012-06-18 10:20:00.540864388 -0400
+@@ -75,27 +75,27 @@
install: build
for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
@@ -33,3 +34,22 @@ Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
@echo "You must put your xinetd.conf in /etc/xinetd.conf"
@echo "There is a sample config file in xinetd/sample.conf and you can"
@echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"
+
+ uninstall:
+- rm -f $(DAEMONDIR)/xinetd
+- rm -f $(DAEMONDIR)/itox
+- rm -f $(DAEMONDIR)/xconv.pl
+- rm -f $(MANDIR)/man5/xinetd.conf.5
+- rm -f $(MANDIR)/man8/xinetd.log.8
+- rm -f $(MANDIR)/man8/xinetd.8
+- rm -f $(MANDIR)/man8/itox.8
++ rm -f $(DESTDIR)$(DAEMONDIR)/xinetd
++ rm -f $(DESTDIR)$(DAEMONDIR)/itox
++ rm -f $(DESTDIR)$(DAEMONDIR)/xconv.pl
++ rm -f $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
++ rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
++ rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.8
++ rm -f $(DESTDIR)$(MANDIR)/man8/itox.8
+
+ distclean: clean
+ rm -f config.cache config.log Makefile config.status xinetd/itox