summaryrefslogtreecommitdiffstats
path: root/package/xinetd/xinetd-002-destdir.patch
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-03-20 22:16:17 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-20 23:28:27 +0100
commit1f721a2f009393c29c6554f643f15f80a8dc5443 (patch)
treefe6b7b28cf5f2bce9e5aa2e837887ad82fcba3f5 /package/xinetd/xinetd-002-destdir.patch
parent77b298c67e4378c53905e504053c38ba52fd0700 (diff)
downloadbuildroot-novena-1f721a2f009393c29c6554f643f15f80a8dc5443.tar.gz
buildroot-novena-1f721a2f009393c29c6554f643f15f80a8dc5443.zip
xinetd: follow the convention for patch location
Following 5538e4766201aa0 ("rework patch model"), the xinetd patches were no longer being applied, because they were stored in package/xinetd/xinetd-2.3.15/*.patch. This lead to xinetd build failures such as: http://autobuild.buildroot.org/results/1a032bca894b76facd9e7f01c3b5d370987d7fc8/build-end.log. This patch fixes this by changing the location and name of the xinetd patches to follow the new conventions. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/xinetd/xinetd-002-destdir.patch')
-rw-r--r--package/xinetd/xinetd-002-destdir.patch55
1 files changed, 55 insertions, 0 deletions
diff --git a/package/xinetd/xinetd-002-destdir.patch b/package/xinetd/xinetd-002-destdir.patch
new file mode 100644
index 000000000..7a323eb68
--- /dev/null
+++ b/package/xinetd/xinetd-002-destdir.patch
@@ -0,0 +1,55 @@
+This patch adds $(DESTDIR) to xinetd's installation paths, to support
+installation to a cross-compiled RFS area.
+
+The content of this patch was inspired by the OpenWrt project:
+https://dev.openwrt.org/browser/packages/net/xinetd/patches/002-destdir.patch
+
+Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
+
+diff -urN xinetd-2.3.15.ORIG/Makefile.in xinetd-2.3.15/Makefile.in
+--- xinetd-2.3.15.ORIG/Makefile.in 2007-09-20 13:01:52.000000000 -0400
++++ xinetd-2.3.15/Makefile.in 2012-06-18 10:20:00.540864388 -0400
+@@ -75,27 +75,27 @@
+
+ install: build
+ for i in $(DAEMONDIR) $(BINDIR) $(MANDIR)/man5 $(MANDIR)/man8 ; do \
+- test -d $$i || mkdir -p $$i ; done
+- $(INSTALL_CMD) -m 755 xinetd/xinetd $(DAEMONDIR)
+- $(INSTALL_CMD) -m 755 xinetd/itox $(DAEMONDIR)
+- $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DAEMONDIR)
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(MANDIR)/man5/xinetd.conf.5
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(MANDIR)/man8/xinetd.log.8
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(MANDIR)/man8/xinetd.8
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(MANDIR)/man8/itox.8
+- $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(MANDIR)/man8/xconv.pl.8
++ test -d $(DESTDIR)$$i || mkdir -p $(DESTDIR)$$i ; done
++ $(INSTALL_CMD) -m 755 xinetd/xinetd $(DESTDIR)$(DAEMONDIR)
++ $(INSTALL_CMD) -m 755 xinetd/itox $(DESTDIR)$(DAEMONDIR)
++ $(INSTALL_CMD) -m 755 $(SRCDIR)/xinetd/xconv.pl $(DESTDIR)$(DAEMONDIR)
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.conf.man $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.log.man $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xinetd.man $(DESTDIR)$(MANDIR)/man8/xinetd.8
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/itox.8 $(DESTDIR)$(MANDIR)/man8/itox.8
++ $(INSTALL_CMD) -m 644 $(SRCDIR)/xinetd/xconv.pl.8 $(DESTDIR)$(MANDIR)/man8/xconv.pl.8
+ @echo "You must put your xinetd.conf in /etc/xinetd.conf"
+ @echo "There is a sample config file in xinetd/sample.conf and you can"
+ @echo "use xconv.pl to convert your old inetd.conf file to an xinetd format"
+
+ uninstall:
+- rm -f $(DAEMONDIR)/xinetd
+- rm -f $(DAEMONDIR)/itox
+- rm -f $(DAEMONDIR)/xconv.pl
+- rm -f $(MANDIR)/man5/xinetd.conf.5
+- rm -f $(MANDIR)/man8/xinetd.log.8
+- rm -f $(MANDIR)/man8/xinetd.8
+- rm -f $(MANDIR)/man8/itox.8
++ rm -f $(DESTDIR)$(DAEMONDIR)/xinetd
++ rm -f $(DESTDIR)$(DAEMONDIR)/itox
++ rm -f $(DESTDIR)$(DAEMONDIR)/xconv.pl
++ rm -f $(DESTDIR)$(MANDIR)/man5/xinetd.conf.5
++ rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.log.8
++ rm -f $(DESTDIR)$(MANDIR)/man8/xinetd.8
++ rm -f $(DESTDIR)$(MANDIR)/man8/itox.8
+
+ distclean: clean
+ rm -f config.cache config.log Makefile config.status xinetd/itox