summaryrefslogtreecommitdiffstats
path: root/package/xerces
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 09:49:42 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 16:04:38 +0200
commitaad29b55a8851dec26399e37f2b87c0b38c98fc3 (patch)
tree72b4f13cb4d51d46a44fd3ff1b452865c7dafe78 /package/xerces
parentd328fef63c7fb3b499a05e4b6cb7c32b795881ea (diff)
downloadbuildroot-novena-aad29b55a8851dec26399e37f2b87c0b38c98fc3.tar.gz
buildroot-novena-aad29b55a8851dec26399e37f2b87c0b38c98fc3.zip
xerces: fix dependency on iconv
All "select BR2_PACKAGE_LIBICONV" must use the "if !BR2_ENABLE_LOCALE" condition, otherwise we can end up with a toolchain suppoting locales *and* the libiconv package being compiled, which confuses other packages. Example with glib: gconvert.c:52:2: error: #error GNU libiconv in use but included iconv.h not from libiconv In addition to that, in xerces.mk, we add the dependency on libiconv when it is available, to make sure it gets compiled before xerces. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/xerces')
-rw-r--r--package/xerces/Config.in2
-rw-r--r--package/xerces/xerces.mk2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/xerces/Config.in b/package/xerces/Config.in
index 85bd96cf1..123f0c166 100644
--- a/package/xerces/Config.in
+++ b/package/xerces/Config.in
@@ -1,7 +1,7 @@
config BR2_PACKAGE_XERCES
bool "xerces-c++"
depends on BR2_INSTALL_LIBSTDCPP
- select BR2_PACKAGE_LIBICONV
+ select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
help
Xerces-C++ is a validating XML parser written in portable C++.
diff --git a/package/xerces/xerces.mk b/package/xerces/xerces.mk
index 9f77be6f7..8a1f693a2 100644
--- a/package/xerces/xerces.mk
+++ b/package/xerces/xerces.mk
@@ -87,7 +87,7 @@ $(TARGET_DIR)/usr/lib/$(LIBXERCES_BINARY): $(STAGING_DIR)/usr/lib/$(LIBXERCES_BI
cp -a $(STAGING_DIR)/usr/lib/$(LIBXERCES_BINARY)* $(TARGET_DIR)/usr/lib
$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/$(LIBXERCES_BINARY)
-xerces: $(TARGET_DIR)/usr/lib/$(LIBXERCES_BINARY)
+xerces: $(if $(BR2_PACKAGE_LIBICONV),libiconv) $(TARGET_DIR)/usr/lib/$(LIBXERCES_BINARY)
xerces-bin: $(XERCES_DIR)/usr/lib/$(LIBXERCES_BINARY)