summaryrefslogtreecommitdiffstats
path: root/package/x11r7/xserver_xorg-server
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2013-01-06 11:29:17 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-09 00:13:29 +0100
commit73a84a6972a062f1b3212e92d91d4b186460c784 (patch)
tree98e2797a7a8019eac678c84267471c6db73e7a86 /package/x11r7/xserver_xorg-server
parent208a81be5b8ecf3108f1f1490a655288a2e7f56a (diff)
downloadbuildroot-novena-73a84a6972a062f1b3212e92d91d4b186460c784.tar.gz
buildroot-novena-73a84a6972a062f1b3212e92d91d4b186460c784.zip
xserver_xorg-server: rename server-style configuration options
The BR2_PACKAGE_XSERVER_xorg and BR2_PACKAGE_XSERVER_tinyx options used to select the style of X.org server to use are not named consistently with the rest of the Buildroot options (in capital letters and prefixed with the package name). Therefore, we rename those options, and we take care to add the old option names in the BR2_LEGACY infrastructure. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/x11r7/xserver_xorg-server')
-rw-r--r--package/x11r7/xserver_xorg-server/Config.in10
-rw-r--r--package/x11r7/xserver_xorg-server/xserver_xorg-server.mk6
2 files changed, 8 insertions, 8 deletions
diff --git a/package/x11r7/xserver_xorg-server/Config.in b/package/x11r7/xserver_xorg-server/Config.in
index e19d356d2..4ac0ec7e8 100644
--- a/package/x11r7/xserver_xorg-server/Config.in
+++ b/package/x11r7/xserver_xorg-server/Config.in
@@ -1,13 +1,13 @@
config BR2_PACKAGE_XSERVER_XORG_SERVER
bool "xorg-server"
- select BR2_PACKAGE_LIBDRM if BR2_PACKAGE_XSERVER_xorg
+ select BR2_PACKAGE_LIBDRM if BR2_PACKAGE_XSERVER_XORG_SERVER_MODULAR
select BR2_PACKAGE_MCOOKIE
select BR2_PACKAGE_OPENSSL
select BR2_PACKAGE_PIXMAN
select BR2_PACKAGE_XFONT_FONT_ALIAS if !BR2_PACKAGE_XSERVER_XORG_SERVER_BUILTIN_FONTS
select BR2_PACKAGE_XFONT_FONT_MISC_MISC if !BR2_PACKAGE_XSERVER_XORG_SERVER_BUILTIN_FONTS
select BR2_PACKAGE_XFONT_FONT_CURSOR_MISC if !BR2_PACKAGE_XSERVER_XORG_SERVER_BUILTIN_FONTS
- select BR2_PACKAGE_XLIB_LIBPCIACCESS if BR2_PACKAGE_XSERVER_xorg
+ select BR2_PACKAGE_XLIB_LIBPCIACCESS if BR2_PACKAGE_XSERVER_XORG_SERVER_MODULAR
select BR2_PACKAGE_XLIB_LIBX11
select BR2_PACKAGE_XLIB_LIBXAU
select BR2_PACKAGE_XLIB_LIBXCURSOR
@@ -61,18 +61,18 @@ if BR2_PACKAGE_XSERVER_XORG_SERVER
choice
prompt "X Window System server type"
- default BR2_PACKAGE_XSERVER_tinyx
+ default BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE
help
Select the X Window System server to use
-config BR2_PACKAGE_XSERVER_xorg
+config BR2_PACKAGE_XSERVER_XORG_SERVER_MODULAR
bool "Modular X.org"
depends on BR2_LARGEFILE && BR2_INSTALL_LIBSTDCPP
comment "X.org requires largefile and C++ support"
depends on !(BR2_LARGEFILE && BR2_INSTALL_LIBSTDCPP)
-config BR2_PACKAGE_XSERVER_tinyx
+config BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE
bool "KDrive / TinyX"
endchoice
diff --git a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
index ed5b904ff..623b25d9a 100644
--- a/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
+++ b/package/x11r7/xserver_xorg-server/xserver_xorg-server.mk
@@ -62,14 +62,14 @@ XSERVER_XORG_SERVER_CONF_OPT = --disable-config-hal \
--with-fontdir=/usr/share/fonts/X11/ --localstatedir=/var \
--$(if $(BR2_PACKAGE_XSERVER_XORG_SERVER_XVFB),en,dis)able-xvfb
-ifeq ($(BR2_PACKAGE_XSERVER_xorg),y)
+ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_MODULAR),y)
XSERVER_XORG_SERVER_CONF_OPT += --enable-xorg
XSERVER_XORG_SERVER_DEPENDENCIES += xlib_libpciaccess libdrm
else
XSERVER_XORG_SERVER_CONF_OPT += --disable-xorg
endif
-ifeq ($(BR2_PACKAGE_XSERVER_tinyx),y)
+ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_KDRIVE),y)
XSERVER_XORG_SERVER_CONF_OPT += --enable-kdrive --enable-xfbdev \
--disable-glx --disable-dri --disable-xsdl
define XSERVER_CREATE_X_SYMLINK
@@ -133,7 +133,7 @@ ifneq ($(BR2_PACKAGE_XLIB_LIBXCOMPOSITE),y)
XSERVER_XORG_SERVER_CONF_OPT += --disable-composite
endif
-ifeq ($(BR2_PACKAGE_XSERVER_xorg),y)
+ifeq ($(BR2_PACKAGE_XSERVER_XORG_SERVER_MODULAR),y)
ifeq ($(BR2_PACKAGE_XPROTO_DRI2PROTO),y)
XSERVER_XORG_SERVER_DEPENDENCIES += xproto_dri2proto
XSERVER_XORG_SERVER_CONF_OPT += --enable-dri2