summaryrefslogtreecommitdiffstats
path: root/package/x11r7/xapp_xauth
diff options
context:
space:
mode:
authorEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
committerEric Andersen <andersen@codepoet.org>2007-08-10 19:07:51 +0000
commita7e49eb2af5d2ca6e53fb908fddfddd92696910a (patch)
treeef6625168d47591f85f98a2014f61bc697cf2427 /package/x11r7/xapp_xauth
parent7aa1c59ebf82bd91a9e2b03178ceb4ce4fbf1b9d (diff)
downloadbuildroot-novena-a7e49eb2af5d2ca6e53fb908fddfddd92696910a.tar.gz
buildroot-novena-a7e49eb2af5d2ca6e53fb908fddfddd92696910a.zip
Merge in X11R7 patches from Julien Letessier, posted 04 Jul 2007. Doesn't
quite work yet for me, but this clearly is a huge project and not having it quite work on the first pass is hardly unexpected. We definately want this stuff in buildroot.
Diffstat (limited to 'package/x11r7/xapp_xauth')
-rw-r--r--package/x11r7/xapp_xauth/Config.in10
-rw-r--r--package/x11r7/xapp_xauth/xapp_xauth-1.0.2-xcb.patch11
-rw-r--r--package/x11r7/xapp_xauth/xapp_xauth.mk13
3 files changed, 34 insertions, 0 deletions
diff --git a/package/x11r7/xapp_xauth/Config.in b/package/x11r7/xapp_xauth/Config.in
new file mode 100644
index 000000000..a91d1436b
--- /dev/null
+++ b/package/x11r7/xapp_xauth/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_XAPP_XAUTH
+ bool "xauth"
+ default n
+ select BR2_PACKAGE_XLIB_LIBX11
+ select BR2_PACKAGE_XLIB_LIBXAU
+ select BR2_PACKAGE_XLIB_LIBXEXT
+ select BR2_PACKAGE_XLIB_LIBXMU
+ help
+ xauth 1.0.2
+ X authority file utility
diff --git a/package/x11r7/xapp_xauth/xapp_xauth-1.0.2-xcb.patch b/package/x11r7/xapp_xauth/xapp_xauth-1.0.2-xcb.patch
new file mode 100644
index 000000000..45b374562
--- /dev/null
+++ b/package/x11r7/xapp_xauth/xapp_xauth-1.0.2-xcb.patch
@@ -0,0 +1,11 @@
+--- xauth-1.0.2/configure.ac.orig 2007-06-06 22:33:44.000000000 +0200
++++ xauth-1.0.2/configure.ac 2007-06-06 22:33:57.000000000 +0200
+@@ -40,7 +40,7 @@
+ AC_CHECK_HEADERS([net/errno.h])
+
+ # Checks for pkg-config packages
+-PKG_CHECK_MODULES(XAUTH, x11 xau xext xmuu)
++PKG_CHECK_MODULES(XAUTH, x11 xau xext xmuu xcb)
+ AC_SUBST(XAUTH_CFLAGS)
+ AC_SUBST(XAUTH_LIBS)
+
diff --git a/package/x11r7/xapp_xauth/xapp_xauth.mk b/package/x11r7/xapp_xauth/xapp_xauth.mk
new file mode 100644
index 000000000..6b890ece9
--- /dev/null
+++ b/package/x11r7/xapp_xauth/xapp_xauth.mk
@@ -0,0 +1,13 @@
+################################################################################
+#
+# xapp_xauth -- X authority file utility
+#
+################################################################################
+
+XAPP_XAUTH_VERSION = 1.0.2
+XAPP_XAUTH_SOURCE = xauth-$(XAPP_XAUTH_VERSION).tar.bz2
+XAPP_XAUTH_SITE = http://xorg.freedesktop.org/releases/individual/app
+XAPP_XAUTH_AUTORECONF = YES
+XAPP_XAUTH_DEPENDANCIES = xlib_libX11 xlib_libXau xlib_libXext xlib_libXmu
+
+$(eval $(call AUTOTARGETS,xapp_xauth))