summaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2012-12-28 09:47:19 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2012-12-28 21:55:48 +0100
commitc89cc4b4b311b927d0c02af5717c6cc1150a1480 (patch)
tree4101e2e4c3a25414b0bab95aa708ee14ccf17e74 /package/wpa_supplicant
parent788fcd99e0578e361f192aae4b89b15f1a60faac (diff)
downloadbuildroot-novena-c89cc4b4b311b927d0c02af5717c6cc1150a1480.tar.gz
buildroot-novena-c89cc4b4b311b927d0c02af5717c6cc1150a1480.zip
wpa_supplicant: remove gnutls support
wpa_supplicant isn't API compatible with gnutls3 so remove support. It's probably hardly used since openssl is far more common, and wpa_supplicant can use its internal routines if it's not available. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk9
1 files changed, 1 insertions, 8 deletions
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 71be11f11..3830d6549 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -59,7 +59,7 @@ define WPA_SUPPLICANT_LIBTOMMATH_CONFIG
$(SED) 's/\(#\)\(CONFIG_INTERNAL_LIBTOMMATH.*\)/\2/' $(WPA_SUPPLICANT_CONFIG)
endef
-# Try to use openssl or gnutls if it's already available
+# Try to use openssl if it's already available
ifeq ($(BR2_PACKAGE_OPENSSL),y)
WPA_SUPPLICANT_DEPENDENCIES += openssl
define WPA_SUPPLICANT_TLS_CONFIG
@@ -67,17 +67,10 @@ define WPA_SUPPLICANT_TLS_CONFIG
$(SED) 's/\(#\)\(CONFIG_EAP_PWD.*\)/\2/' $(WPA_SUPPLICANT_CONFIG)
endef
else
-ifeq ($(BR2_PACKAGE_GNUTLS),y)
- WPA_SUPPLICANT_DEPENDENCIES += gnutls
-define WPA_SUPPLICANT_TLS_CONFIG
- $(SED) 's/\(#\)\(CONFIG_TLS=\).*/\2gnutls/' $(WPA_SUPPLICANT_CONFIG)
-endef
-else
define WPA_SUPPLICANT_TLS_CONFIG
$(SED) 's/\(#\)\(CONFIG_TLS=\).*/\2internal/' $(WPA_SUPPLICANT_CONFIG)
endef
endif
-endif
ifeq ($(BR2_PACKAGE_DBUS),y)
WPA_SUPPLICANT_DEPENDENCIES += host-pkgconf dbus