summaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorDaniel Mack <zonque@gmail.com>2011-12-05 13:33:18 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2011-12-07 21:03:16 +0100
commita15d47f09014441482eb97b1316f0509fd07db99 (patch)
tree524de0f42dd53e790dcafa7bd236520e2e97733a /package/wpa_supplicant
parent88f95f82b71faf845a0041c93011939d8f560350 (diff)
downloadbuildroot-novena-a15d47f09014441482eb97b1316f0509fd07db99.tar.gz
buildroot-novena-a15d47f09014441482eb97b1316f0509fd07db99.zip
wpa_supplicant: add CONFIG_AP support
[Peter: Fix indentation] Signed-off-by: Daniel Mack <zonque@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/Config.in8
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk11
2 files changed, 19 insertions, 0 deletions
diff --git a/package/wpa_supplicant/Config.in b/package/wpa_supplicant/Config.in
index e3df2b4d8..a4e0fba0f 100644
--- a/package/wpa_supplicant/Config.in
+++ b/package/wpa_supplicant/Config.in
@@ -23,3 +23,11 @@ config BR2_PACKAGE_WPA_SUPPLICANT_PASSPHRASE
help
Install wpa_passphrase command line utility
+config BR2_PACKAGE_WPA_SUPPLICANT_AP_SUPPORT
+ bool "Enable support for soft AP"
+ depends on BR2_PACKAGE_WPA_SUPPLICANT
+ help
+ With this option enabled, wpa_supplicant can act as
+ access point. This can be used for open and WPA2-Personal networks
+ (optionally, with WPS); this links in parts of hostapd functionality
+ into wpa_supplicant.
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index b2e7be3b3..baa739bfd 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -25,6 +25,16 @@ define WPA_SUPPLICANT_EAP_CONFIG
endef
endif
+ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_AP_SUPPORT),y)
+define WPA_SUPPLICANT_AP_CONFIG
+ echo "CONFIG_AP=y" >>$(WPA_SUPPLICANT_CONFIG)
+endef
+else
+define WPA_SUPPLICANT_AP_CONFIG
+ $(SED) "s/^CONFIG_AP=y//" $(WPA_SUPPLICANT_CONFIG)
+endef
+endif
+
define WPA_SUPPLICANT_CRYPTO_CONFIG
echo "CONFIG_CRYPTO=internal" >>$(WPA_SUPPLICANT_CONFIG)
echo "CONFIG_INTERNAL_LIBTOMMATH=y" >>$(WPA_SUPPLICANT_CONFIG)
@@ -69,6 +79,7 @@ define WPA_SUPPLICANT_CONFIGURE_CMDS
$(WPA_SUPPLICANT_EAP_CONFIG)
$(WPA_SUPPLICANT_LIBNL_CONFIG)
$(WPA_SUPPLICANT_DBUS_CONFIG)
+ $(WPA_SUPPLICANT_AP_CONFIG)
endef
define WPA_SUPPLICANT_REMOVE_CLI