summaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-10-05 10:30:31 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-10-05 11:10:30 +0200
commit656ad7347ef6fa50496b9bcafae604148d1aacc5 (patch)
tree68747243e680e7c33cb59f067e0fb4ce94de829e /package/wpa_supplicant
parent5f4154801223e1689af3d720634ee3118245fe58 (diff)
downloadbuildroot-novena-656ad7347ef6fa50496b9bcafae604148d1aacc5.tar.gz
buildroot-novena-656ad7347ef6fa50496b9bcafae604148d1aacc5.zip
wpa_supplicant: adjust make environment for pkg-config call
In case that wpa_supplicant is configured with DBus interface, it calls pkg-config to find the dbus headers and libraries. Adjust the make environment so that it will use the right pkg-config search paths. Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 4195b1cf1..5d7857389 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -19,7 +19,10 @@ ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_OPENSSL),y)
WPA_SUPPLICANT_DEPENDENCIES += openssl
endif
ifeq ($(BR2_PACKAGE_DBUS),y)
- WPA_SUPPLICANT_DEPENDENCIES += dbus
+ WPA_SUPPLICANT_DEPENDENCIES += host-pkgconfig dbus
+ WPA_SUPPLICANT_MAKE_ENV = \
+ PKG_CONFIG_SYSROOT_DIR="$(STAGING_DIR)" \
+ PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig"
endif
$(eval $(call AUTOTARGETS,package,wpa_supplicant))