summaryrefslogtreecommitdiffstats
path: root/package/wpa_supplicant
diff options
context:
space:
mode:
authorSven Neumann <s.neumann@raumfeld.com>2009-07-20 22:11:42 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2009-07-20 22:11:42 +0200
commit321c254be5342fc8698dfa5604a2e2301dbc5588 (patch)
tree97f5615f157285e3117448ae78757f10415272a2 /package/wpa_supplicant
parent214da03d145fd7cd1fd2ac3ec6a44ca76e00e2c2 (diff)
downloadbuildroot-novena-321c254be5342fc8698dfa5604a2e2301dbc5588.tar.gz
buildroot-novena-321c254be5342fc8698dfa5604a2e2301dbc5588.zip
wpa_supplicant: add optional dbus support
Signed-off-by: Sven Neumann <s.neumann@raumfeld.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wpa_supplicant')
-rw-r--r--package/wpa_supplicant/wpa_supplicant.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/wpa_supplicant/wpa_supplicant.mk b/package/wpa_supplicant/wpa_supplicant.mk
index 2cceeb3c1..eaa6ab42e 100644
--- a/package/wpa_supplicant/wpa_supplicant.mk
+++ b/package/wpa_supplicant/wpa_supplicant.mk
@@ -13,10 +13,14 @@ WPA_SUPPLICANT_DEPENDENCIES = uclibc
WPA_SUPPLICANT_CONFIG = $(WPA_SUPPLICANT_DIR)/wpa_supplicant/.config
WPA_SUPPLICANT_SUBDIR = wpa_supplicant
WPA_SUPPLICANT_TARGET_BINS = wpa_cli wpa_supplicant wpa_passphrase
+WPA_SUPPLICANT_DBUS_SERVICE = fi.epitest.hostap.WPASupplicant
ifeq ($(BR2_PACKAGE_WPA_SUPPLICANT_OPENSSL),y)
WPA_SUPPLICANT_DEPENDENCIES += openssl
endif
+ifeq ($(BR2_PACKAGE_DBUS),y)
+ WPA_SUPPLICANT_DEPENDENCIES += dbus
+endif
$(eval $(call AUTOTARGETS,package,wpa_supplicant))
@@ -36,6 +40,9 @@ else
echo "CONFIG_INTERNAL_LIBTOMMATH=y" >>$(WPA_SUPPLICANT_CONFIG)
endif
endif
+ifeq ($(BR2_PACKAGE_DBUS),y)
+ echo "CONFIG_CTRL_IFACE_DBUS=y" >>$(WPA_SUPPLICANT_CONFIG)
+endif
touch $@
$(WPA_SUPPLICANT_HOOK_POST_INSTALL):
@@ -45,9 +52,19 @@ endif
ifneq ($(BR2_PACKAGE_WPA_SUPPLICANT_PASSPHRASE),y)
rm -f $(TARGET_DIR)/usr/sbin/wpa_passphrase
endif
+ifeq ($(BR2_PACKAGE_DBUS),y)
+ $(INSTALL) -D \
+ $(WPA_SUPPLICANT_DIR)/wpa_supplicant/dbus-wpa_supplicant.conf \
+ $(TARGET_DIR)/etc/dbus-1/system.d/wpa_supplicant.conf
+ $(INSTALL) -D \
+ $(WPA_SUPPLICANT_DIR)/wpa_supplicant/dbus-wpa_supplicant.service \
+ $(TARGET_DIR)/usr/share/dbus-1/system-services/$(WPA_SUPPLICANT_DBUS_SERVICE).service
+endif
$(WPA_SUPPLICANT_TARGET_UNINSTALL):
$(call MESSAGE,"Uninstalling")
rm -f $(addprefix $(TARGET_DIR)/usr/sbin/, $(WPA_SUPPLICANT_TARGET_BINS))
+ rm -f $(TARGET_DIR)/etc/dbus-1/system.d/wpa_supplicant.conf
+ rm -f $(TARGET_DIR)/usr/share/dbus-1/system-services/$(WPA_SUPPLICANT_DBUS_SERVICE).service
rm -f $(WPA_SUPPLICANT_TARGET_INSTALL_TARGET) $(WPA_SUPPLICANT_HOOK_POST_INSTALL)