summaryrefslogtreecommitdiffstats
path: root/package/wget
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2011-10-15 00:07:33 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-15 23:20:28 +0200
commitb79ab02d462596566f8f2e2db518dad158bae5eb (patch)
tree630a10cf3df381fd57e81a237205b5819716b2f2 /package/wget
parentc245be2bc7f427a51a673a1d64c951ee63a1afb9 (diff)
downloadbuildroot-novena-b79ab02d462596566f8f2e2db518dad158bae5eb.tar.gz
buildroot-novena-b79ab02d462596566f8f2e2db518dad158bae5eb.zip
wget: bump to version 1.13.4 and improvements
* Bump wget to version 1.13.4 * Enable wget again on !wchar toolchains * Enable support for gnutls Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wget')
-rw-r--r--package/wget/Config.in4
-rw-r--r--package/wget/wget.mk22
2 files changed, 20 insertions, 6 deletions
diff --git a/package/wget/Config.in b/package/wget/Config.in
index 172359c24..3877a3af5 100644
--- a/package/wget/Config.in
+++ b/package/wget/Config.in
@@ -1,10 +1,6 @@
config BR2_PACKAGE_WGET
bool "wget"
- depends on BR2_USE_WCHAR
help
Network utility to retrieve files from http, https and ftp.
http://www.gnu.org/software/wget/
-
-comment "wget requires a toolchain with WCHAR support"
- depends on !BR2_USE_WCHAR
diff --git a/package/wget/wget.mk b/package/wget/wget.mk
index c34a51c42..b14cd92bb 100644
--- a/package/wget/wget.mk
+++ b/package/wget/wget.mk
@@ -4,12 +4,30 @@
#
#############################################################
-WGET_VERSION = 1.12
+WGET_VERSION = 1.13.4
WGET_SITE = $(BR2_GNU_MIRROR)/wget
+# Prefer full-blown wget over busybox
+ifeq ($(BR2_PACKAGE_BUSYBOX),y)
+ WGET_DEPENDENCIES += busybox
+endif
+
+ifeq ($(BR2_PACKAGE_GNUTLS),y)
+ WGET_CONF_OPT += --with-ssl=gnutls \
+ --with-libgnutls-prefix=$(STAGING_DIR)
+ WGET_DEPENDENCIES += gnutls
+endif
+
ifeq ($(BR2_PACKAGE_OPENSSL),y)
- WGET_CONF_OPT += --with-ssl --with-libssl-prefix=$(STAGING_DIR)
+ WGET_CONF_OPT += --with-ssl=openssl --with-libssl-prefix=$(STAGING_DIR)
WGET_DEPENDENCIES += openssl
endif
+# --with-ssl is default
+ifneq ($(BR2_PACKAGE_GNUTLS),y)
+ifneq ($(BR2_PACKAGE_OPENSSL),y)
+ WGET_CONF_OPT += --without-ssl
+endif
+endif
+
$(eval $(call AUTOTARGETS))