summaryrefslogtreecommitdiffstats
path: root/package/wget
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2010-02-18 14:51:51 -0300
committerPeter Korsgaard <jacmet@sunsite.dk>2010-03-22 14:07:30 +0100
commit8fe6cc98d9211fbb5d7e18f16cc97d4a525a0126 (patch)
tree1f2522b33fa98faa7b557c6fc4514ea144e10bbf /package/wget
parenta7d8592333fc89d667562688703ad405121fb575 (diff)
downloadbuildroot-novena-8fe6cc98d9211fbb5d7e18f16cc97d4a525a0126.tar.gz
buildroot-novena-8fe6cc98d9211fbb5d7e18f16cc97d4a525a0126.zip
wget: bump to 1.12 and migrate to Makefile.autotools.in
Closes #1111. Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/wget')
-rw-r--r--package/wget/Config.in4
-rw-r--r--package/wget/wget.mk60
2 files changed, 10 insertions, 54 deletions
diff --git a/package/wget/Config.in b/package/wget/Config.in
index b53cc9513..3877a3af5 100644
--- a/package/wget/Config.in
+++ b/package/wget/Config.in
@@ -1,6 +1,6 @@
config BR2_PACKAGE_WGET
bool "wget"
help
- Network utility to retrieve files from http/ftp/etc...
+ Network utility to retrieve files from http, https and ftp.
- http://wget.sunsite.dk/
+ http://www.gnu.org/software/wget/
diff --git a/package/wget/wget.mk b/package/wget/wget.mk
index 06e54c745..cb0c60aa3 100644
--- a/package/wget/wget.mk
+++ b/package/wget/wget.mk
@@ -3,58 +3,14 @@
# wget
#
#############################################################
-WGET_VERSION:=1.10.2
-WGET_SOURCE:=wget-$(WGET_VERSION).tar.gz
-WGET_SITE:=$(BR2_GNU_MIRROR)/wget
-WGET_DIR:=$(BUILD_DIR)/wget-$(WGET_VERSION)
-WGET_CAT:=$(ZCAT)
-WGET_BINARY:=src/wget
-WGET_TARGET_BINARY:=bin/wget
-$(DL_DIR)/$(WGET_SOURCE):
- $(call DOWNLOAD,$(WGET_SITE),$(WGET_SOURCE))
+WGET_VERSION = 1.12
+WGET_SITE = $(BR2_GNU_MIRROR)/wget
+WGET_CONF_OPT = $(DISABLE_IPV6)
-wget-source: $(DL_DIR)/$(WGET_SOURCE)
-
-$(WGET_DIR)/.unpacked: $(DL_DIR)/$(WGET_SOURCE)
- $(WGET_CAT) $(DL_DIR)/$(WGET_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
- $(CONFIG_UPDATE) $(WGET_DIR)
- touch $@
-
-$(WGET_DIR)/.configured: $(WGET_DIR)/.unpacked
- (cd $(WGET_DIR); rm -rf config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- $(TARGET_CONFIGURE_ARGS) \
- ./configure $(QUIET) \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --prefix=/ \
- --disable-ipv6 \
- $(DISABLE_NLS) \
- --without-ssl \
- )
- touch $@
-
-$(WGET_DIR)/$(WGET_BINARY): $(WGET_DIR)/.configured
- $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(WGET_DIR)
-
-$(TARGET_DIR)/$(WGET_TARGET_BINARY): $(WGET_DIR)/$(WGET_BINARY)
- install -D $(WGET_DIR)/$(WGET_BINARY) $(TARGET_DIR)/$(WGET_TARGET_BINARY)
-
-wget: $(TARGET_DIR)/$(WGET_TARGET_BINARY)
-
-wget-clean:
- rm -f $(TARGET_DIR)/$(WGET_TARGET_BINARY)
- -$(MAKE) -C $(WGET_DIR) clean
-
-wget-dirclean:
- rm -rf $(WGET_DIR)
-#############################################################
-#
-# Toplevel Makefile options
-#
-#############################################################
-ifeq ($(BR2_PACKAGE_WGET),y)
-TARGETS+=wget
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
+ WGET_CONF_OPT += --with-ssl --with-libssl-prefix=$(STAGING_DIR)
+ WGET_DEPENDENCIES += openssl
endif
+
+$(eval $(call AUTOTARGETS,package,wget))